summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_2.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_2.1.1.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_2.1.1.bb148
1 files changed, 148 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_2.1.1.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_2.1.1.bb
new file mode 100644
index 0000000000..bdf0efa330
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_2.1.1.bb
@@ -0,0 +1,148 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN} = "${PN}-client bash"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15inherit useradd
16
17USERADD_PACKAGES = "${PN}-client"
18USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
19 --shell /bin/false --user-group rpcuser"
20
21SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
22 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
23 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
24 file://nfsserver \
25 file://nfscommon \
26 file://nfs-utils.conf \
27 file://nfs-server.service \
28 file://nfs-mountd.service \
29 file://nfs-statd.service \
30 file://proc-fs-nfsd.mount \
31 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
32 file://nfs-utils-debianize-start-statd.patch \
33 file://bugfix-adjust-statd-service-name.patch \
34"
35
36SRC_URI[md5sum] = "59dfcb2e6254b129f901f40c86086b13"
37SRC_URI[sha256sum] = "0faeb54c70b84e6bd3b9b6901544b1f6add8d246f35c1683e402daf4e0c719ef"
38
39# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
40# pull in the remainder of the dependencies.
41
42INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
43INITSCRIPT_NAME = "nfsserver"
44INITSCRIPT_PARAMS = "defaults"
45INITSCRIPT_NAME_${PN}-client = "nfscommon"
46INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
47
48inherit autotools-brokensep update-rc.d systemd pkgconfig
49
50SYSTEMD_PACKAGES = "${PN} ${PN}-client"
51SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
52SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
53
54# --enable-uuid is need for cross-compiling
55EXTRA_OECONF = "--with-statduser=rpcuser \
56 --enable-mountconfig \
57 --enable-libmount-mount \
58 --disable-nfsv41 \
59 --enable-uuid \
60 --disable-gss \
61 --disable-nfsdcltrack \
62 --with-statdpath=/var/lib/nfs/statd \
63 "
64
65PACKAGECONFIG ??= "tcp-wrappers \
66 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
67"
68PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
69PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
70PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
71PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
72
73PACKAGES =+ "${PN}-client ${PN}-mount ${PN}-stats"
74
75CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
76 ${localstatedir}/lib/nfs/rmtab \
77 ${localstatedir}/lib/nfs/xtab \
78 ${localstatedir}/lib/nfs/statd/state \
79 ${sysconfdir}/nfsmount.conf"
80
81FILES_${PN}-client = "${sbindir}/*statd \
82 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
83 ${sbindir}/showmount ${sbindir}/nfsstat \
84 ${localstatedir}/lib/nfs \
85 ${sysconfdir}/nfs-utils.conf \
86 ${sysconfdir}/nfsmount.conf \
87 ${sysconfdir}/init.d/nfscommon \
88 ${systemd_unitdir}/system/nfs-statd.service"
89RDEPENDS_${PN}-client = "${PN}-mount rpcbind"
90
91FILES_${PN}-mount = "${base_sbindir}/*mount.nfs*"
92
93FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
94RDEPENDS_${PN}-stats = "python3-core"
95
96FILES_${PN} += "${systemd_unitdir}"
97
98do_configure_prepend() {
99 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
100 ${S}/utils/mount/Makefile.am
101
102 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
103 ${S}/utils/osd_login/Makefile.am
104}
105
106# Make clean needed because the package comes with
107# precompiled 64-bit objects that break the build
108do_compile_prepend() {
109 make clean
110}
111
112do_install_append () {
113 install -d ${D}${sysconfdir}/init.d
114 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
115 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
116
117 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
118 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
119
120 install -d ${D}${systemd_unitdir}/system
121 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
122 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
123 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
124 sed -i -e 's,@SBINDIR@,${sbindir},g' \
125 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
126 ${D}${systemd_unitdir}/system/*.service
127 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
128 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
129 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
130 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
131 fi
132
133 # kernel code as of 3.8 hard-codes this path as a default
134 install -d ${D}/var/lib/nfs/v4recovery
135
136 # chown the directories and files
137 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
138 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
139
140 # the following are built by CC_FOR_BUILD
141 rm -f ${D}${sbindir}/rpcdebug
142 rm -f ${D}${sbindir}/rpcgen
143 rm -f ${D}${sbindir}/locktest
144
145 # Make python tools use python 3
146 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${sbindir}/mountstats ${D}${sbindir}/nfsiostat
147
148}