summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/neard/neard_0.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/neard/neard_0.19.bb')
-rw-r--r--meta/recipes-connectivity/neard/neard_0.19.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/neard/neard_0.19.bb b/meta/recipes-connectivity/neard/neard_0.19.bb
new file mode 100644
index 0000000000..a98f436b98
--- /dev/null
+++ b/meta/recipes-connectivity/neard/neard_0.19.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Linux NFC daemon"
2DESCRIPTION = "A daemon for the Linux Near Field Communication stack"
3HOMEPAGE = "http://01.org/linux-nfc"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
6 file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \
7 "
8
9DEPENDS = "dbus glib-2.0 libnl autoconf-archive-native"
10
11SRC_URI = "git://git.kernel.org/pub/scm/network/nfc/neard.git;protocol=https;branch=master \
12 file://neard.in \
13 file://Makefile.am-fix-parallel-issue.patch \
14 file://Makefile.am-do-not-ship-version.h.patch \
15 file://0001-Add-header-dependency-to-nciattach.o.patch \
16 "
17
18SRCREV = "a1dc8a75cba999728e154a0f811ab9dd50c809f7"
19
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig systemd update-rc.d
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
25
26PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir}/ --with-systemduserunitdir=${systemd_unitdir}/user/,--disable-systemd"
27
28EXTRA_OECONF += "--enable-tools"
29
30# This would copy neard start-stop shell and test scripts
31do_install:append() {
32 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
33 install -d ${D}${sysconfdir}/init.d/
34 sed "s:@installpath@:${libexecdir}/nfc:" ${WORKDIR}/neard.in \
35 > ${D}${sysconfdir}/init.d/neard
36 chmod 0755 ${D}${sysconfdir}/init.d/neard
37 fi
38}
39
40RDEPENDS:${PN} = "dbus"
41
42# Bluez & Wifi are not mandatory except for handover
43RRECOMMENDS:${PN} = "\
44 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
45 ${@bb.utils.contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
46 "
47
48INITSCRIPT_NAME = "neard"
49INITSCRIPT_PARAMS = "defaults 64"
50
51SYSTEMD_SERVICE:${PN} = "neard.service"