summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/neard/neard_0.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/neard/neard_0.16.bb')
-rw-r--r--meta/recipes-connectivity/neard/neard_0.16.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/neard/neard_0.16.bb b/meta/recipes-connectivity/neard/neard_0.16.bb
new file mode 100644
index 0000000000..5433dc3c3e
--- /dev/null
+++ b/meta/recipes-connectivity/neard/neard_0.16.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Linux NFC daemon"
2DESCRIPTION = "A daemon for the Linux Near Field Communication stack"
3HOMEPAGE = "http://01.org/linux-nfc"
4LICENSE = "GPLv2"
5
6DEPENDS = "dbus glib-2.0 libnl"
7
8SRC_URI = "${KERNELORG_MIRROR}/linux/network/nfc/${BP}.tar.xz \
9 file://neard.in \
10 file://Makefile.am-fix-parallel-issue.patch \
11 file://Makefile.am-do-not-ship-version.h.patch \
12 "
13SRC_URI[md5sum] = "5c691fb7872856dc0d909c298bc8cb41"
14SRC_URI[sha256sum] = "eae3b11c541a988ec11ca94b7deab01080cd5b58cfef3ced6ceac9b6e6e65b36"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
17 file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \
18 "
19
20inherit autotools pkgconfig systemd update-rc.d bluetooth
21
22PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
23
24PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-systemduserunitdir=${systemd_unitdir}/user/,--disable-systemd"
25
26EXTRA_OECONF += "--enable-tools"
27
28# This would copy neard start-stop shell and test scripts
29do_install_append() {
30 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
31 install -d ${D}${sysconfdir}/init.d/
32 sed "s:@installpath@:${libexecdir}/nfc:" ${WORKDIR}/neard.in \
33 > ${D}${sysconfdir}/init.d/neard
34 chmod 0755 ${D}${sysconfdir}/init.d/neard
35 fi
36}
37
38RDEPENDS_${PN} = "dbus"
39
40# Bluez & Wifi are not mandatory except for handover
41RRECOMMENDS_${PN} = "\
42 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
44 "
45
46INITSCRIPT_NAME = "neard"
47INITSCRIPT_PARAMS = "defaults 64"
48
49SYSTEMD_SERVICE_${PN} = "neard.service"