summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/libpcap/libpcap_1.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/libpcap/libpcap_1.10.0.bb')
-rw-r--r--meta/recipes-connectivity/libpcap/libpcap_1.10.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.0.bb b/meta/recipes-connectivity/libpcap/libpcap_1.10.0.bb
new file mode 100644
index 0000000000..967eabcc13
--- /dev/null
+++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
13SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz \
14 "
15SRC_URI[md5sum] = "8c12dc19dd7e0d02d2bb6596eb5a71c7"
16SRC_URI[sha256sum] = "8d12b42623eeefee872f123bd0dc85d535b00df4d42e865f993c40f7bfc92b1e"
17
18inherit autotools binconfig-disabled pkgconfig
19
20BINCONFIG = "${bindir}/pcap-config"
21
22# Explicitly disable dag support. We don't have recipe for it and if enabled here,
23# configure script poisons the include dirs with /usr/local/include even when the
24# support hasn't been detected.
25EXTRA_OECONF = " \
26 --with-pcap=linux \
27 --without-dag \
28 "
29EXTRA_AUTORECONF += "--exclude=aclocal"
30
31PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
32 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
33"
34PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
35PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
36PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
37PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
38
39do_configure_prepend () {
40 #remove hardcoded references to /usr/include
41 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
42}
43
44BBCLASSEXTEND = "native"