summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/kea/kea_1.7.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/kea/kea_1.7.10.bb')
-rw-r--r--meta/recipes-connectivity/kea/kea_1.7.10.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/kea/kea_1.7.10.bb b/meta/recipes-connectivity/kea/kea_1.7.10.bb
new file mode 100644
index 0000000000..e2560b2399
--- /dev/null
+++ b/meta/recipes-connectivity/kea/kea_1.7.10.bb
@@ -0,0 +1,59 @@
1SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa"
7
8DEPENDS = "boost log4cplus openssl"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
12 file://kea-dhcp4.service \
13 file://kea-dhcp6.service \
14 file://kea-dhcp-ddns.service \
15"
16SRC_URI[sha256sum] = "4e121f0e58b175a827581c69cb1d60778647049fa47f142940dddc9ce58f3c82"
17
18inherit autotools systemd
19
20SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
21SYSTEMD_AUTO_ENABLE = "disable"
22
23DEBUG_OPTIMIZATION_remove_mips = " -Og"
24DEBUG_OPTIMIZATION_append_mips = " -O"
25BUILD_OPTIMIZATION_remove_mips = " -Og"
26BUILD_OPTIMIZATION_append_mips = " -O"
27
28DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
29DEBUG_OPTIMIZATION_append_mipsel = " -O"
30BUILD_OPTIMIZATION_remove_mipsel = " -Og"
31BUILD_OPTIMIZATION_append_mipsel = " -O"
32
33EXTRA_OECONF = "--with-boost-libs=-lboost_system \
34 --with-log4cplus=${STAGING_DIR_TARGET}${prefix} \
35 --with-openssl=${STAGING_DIR_TARGET}${prefix}"
36
37do_configure_prepend() {
38 # replace abs_top_builddir to avoid introducing the build path
39 # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
40 find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
41 sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in
42}
43
44do_install_append() {
45 install -d ${D}${systemd_system_unitdir}
46 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
47 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
48 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
49 ${D}${systemd_system_unitdir}/kea-dhcp*service
50}
51
52do_install_append() {
53 rm -rf "${D}${localstatedir}"
54}
55
56FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
57FILES_${PN} += "${libdir}/hooks/*.so"
58
59PARALLEL_MAKEINST = ""