summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/iw/iw_6.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/iw/iw_6.7.bb')
-rw-r--r--meta/recipes-connectivity/iw/iw_6.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/iw/iw_6.7.bb b/meta/recipes-connectivity/iw/iw_6.7.bb
new file mode 100644
index 0000000000..b46b54bc93
--- /dev/null
+++ b/meta/recipes-connectivity/iw/iw_6.7.bb
@@ -0,0 +1,31 @@
1SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
17SRC_URI[sha256sum] = "b3ef3fa85fa1177b11d3e97d6d38cdfe10ee250ca31482b581f3bd0fc79cb015"
18
19inherit pkgconfig
20
21EXTRA_OEMAKE = "\
22 -f '${S}/Makefile' \
23 \
24 'PREFIX=${prefix}' \
25 'SBINDIR=${sbindir}' \
26 'MANDIR=${mandir}' \
27"
28
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31}