summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/dhcpcd/dhcpcd_10.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/dhcpcd/dhcpcd_10.0.6.bb')
-rw-r--r--meta/recipes-connectivity/dhcpcd/dhcpcd_10.0.6.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/dhcpcd/dhcpcd_10.0.6.bb b/meta/recipes-connectivity/dhcpcd/dhcpcd_10.0.6.bb
new file mode 100644
index 0000000000..6bde9b1f51
--- /dev/null
+++ b/meta/recipes-connectivity/dhcpcd/dhcpcd_10.0.6.bb
@@ -0,0 +1,61 @@
1SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=ba9c7e534853aaf3de76c905b2410ffd"
11
12SRC_URI = "git://github.com/NetworkConfiguration/dhcpcd;protocol=https;branch=master \
13 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
14 file://0001-20-resolv.conf-improve-the-sitation-of-working-with-.patch \
15 file://dhcpcd.service \
16 file://dhcpcd@.service \
17 file://0001-dhcpcd.8-Fix-conflict-error-when-enable-multilib.patch \
18 "
19
20SRCREV = "1c8ae59836fa87b4c63c598087f0460ec20ed862"
21S = "${WORKDIR}/git"
22
23inherit pkgconfig autotools-brokensep systemd useradd
24
25SYSTEMD_SERVICE:${PN} = "dhcpcd.service"
26
27PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
28
29PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
30PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
31# ntp conflicts with chrony
32PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
33PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
34PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
35
36# add option to override DBDIR location
37DBDIR ?= "${localstatedir}/lib/${BPN}"
38
39EXTRA_OECONF = "--enable-ipv4 \
40 --dbdir=${DBDIR} \
41 --sbindir=${base_sbindir} \
42 --runstatedir=/run \
43 --enable-privsep \
44 --privsepuser=dhcpcd \
45 --with-hooks \
46 --with-eghooks \
47 "
48
49USERADD_PACKAGES = "${PN}"
50USERADD_PARAM:${PN} = "--system -d ${DBDIR} -M -s /bin/false -U dhcpcd"
51
52do_install:append () {
53 # install systemd unit files
54 install -d ${D}${systemd_system_unitdir}
55 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir}
56
57 chmod 700 ${D}${DBDIR}
58 chown dhcpcd:dhcpcd ${D}${DBDIR}
59}
60
61FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"