summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.10.3-P3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.10.3-P3.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.10.3-P3.bb106
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.10.3-P3.bb b/meta/recipes-connectivity/bind/bind_9.10.3-P3.bb
new file mode 100644
index 0000000000..da414c00da
--- /dev/null
+++ b/meta/recipes-connectivity/bind/bind_9.10.3-P3.bb
@@ -0,0 +1,106 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "http://www.isc.org/sw/bind/"
3SECTION = "console/network"
4
5LICENSE = "ISC & BSD"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=0a95f52a0ab6c5f52dedc9a45e7abb3f"
7
8DEPENDS = "openssl libcap"
9
10SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
11 file://conf.patch \
12 file://make-etc-initd-bind-stop-work.patch \
13 file://mips1-not-support-opcode.diff \
14 file://dont-test-on-host.patch \
15 file://generate-rndc-key.sh \
16 file://named.service \
17 file://bind9 \
18 file://init.d-add-support-for-read-only-rootfs.patch \
19 file://bind-confgen-build-unix.o-once.patch \
20 file://0001-build-use-pkg-config-to-find-libxml2.patch \
21 file://bind-ensure-searching-for-json-headers-searches-sysr.patch \
22 file://0001-gen.c-extend-DIRNAMESIZE-from-256-to-512.patch \
23 file://0001-lib-dns-gen.c-fix-too-long-error.patch \
24 "
25
26SRC_URI[md5sum] = "bcf7e772b616f7259420a3edc5df350a"
27SRC_URI[sha256sum] = "690810d1fbb72afa629e74638d19cd44e28d2b2e5eb63f55c705ad85d1a4cb83"
28
29ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}"
30EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \
31 --disable-devpoll --disable-epoll --with-gost=no \
32 --with-gssapi=no --with-ecdsa=yes \
33 --sysconfdir=${sysconfdir}/bind \
34 --with-openssl=${STAGING_LIBDIR}/.. \
35 "
36inherit autotools update-rc.d systemd useradd pkgconfig
37
38# PACKAGECONFIGs readline and libedit should NOT be set at same time
39PACKAGECONFIG ?= "readline"
40PACKAGECONFIG[httpstats] = "--with-libxml2,--without-libxml2,libxml2"
41PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline"
42PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit"
43
44USERADD_PACKAGES = "${PN}"
45USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \
46 --user-group bind"
47
48INITSCRIPT_NAME = "bind"
49INITSCRIPT_PARAMS = "defaults"
50
51SYSTEMD_SERVICE_${PN} = "named.service"
52
53PARALLEL_MAKE = ""
54
55RDEPENDS_${PN} = "python-core"
56RDEPENDS_${PN}-dev = ""
57
58PACKAGE_BEFORE_PN += "${PN}-utils"
59FILES_${PN}-utils = "${bindir}/host ${bindir}/dig"
60FILES_${PN}-dev += "${bindir}/isc-config.h"
61FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
62
63do_install_prepend() {
64 # clean host path in isc-config.sh before the hardlink created
65 # by "make install":
66 # bind9-config -> isc-config.sh
67 sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh
68}
69
70do_install_append() {
71 rm "${D}${bindir}/nslookup"
72 rm "${D}${mandir}/man1/nslookup.1"
73 rmdir "${D}${localstatedir}/run"
74 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
75 install -d "${D}${localstatedir}/cache/bind"
76 install -d "${D}${sysconfdir}/bind"
77 install -d "${D}${sysconfdir}/init.d"
78 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
79 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
80 sed -i -e '1s,#!.*python,#! /usr/bin/env python,' ${D}${sbindir}/dnssec-coverage ${D}${sbindir}/dnssec-checkds
81
82 # Install systemd related files
83 install -d ${D}${localstatedir}/cache/bind
84 install -d ${D}${sbindir}
85 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
86 install -d ${D}${systemd_unitdir}/system
87 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system
88 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
89 -e 's,@SBINDIR@,${sbindir},g' \
90 ${D}${systemd_unitdir}/system/named.service
91
92 install -d ${D}${sysconfdir}/default
93 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
94}
95
96CONFFILES_${PN} = " \
97 ${sysconfdir}/bind/named.conf \
98 ${sysconfdir}/bind/named.conf.local \
99 ${sysconfdir}/bind/named.conf.options \
100 ${sysconfdir}/bind/db.0 \
101 ${sysconfdir}/bind/db.127 \
102 ${sysconfdir}/bind/db.empty \
103 ${sysconfdir}/bind/db.local \
104 ${sysconfdir}/bind/db.root \
105 "
106