summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/usbinit/usbinit.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/usbinit/usbinit.bb')
-rw-r--r--meta/recipes-bsp/usbinit/usbinit.bb24
1 files changed, 0 insertions, 24 deletions
diff --git a/meta/recipes-bsp/usbinit/usbinit.bb b/meta/recipes-bsp/usbinit/usbinit.bb
deleted file mode 100644
index 3a50b835c2..0000000000
--- a/meta/recipes-bsp/usbinit/usbinit.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "Initscript for enabling USB gadget Ethernet"
2DESCRIPTION = "This module allows ethernet emulation over USB, allowing for \
3all sorts of nifty things like SSH and NFS in one go plus charging over the \
4same wire, at higher speeds than most Wifi connections."
5HOMEPAGE = "http://linux-sunxi.org/USB_Gadget/Ethernet"
6
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
9
10
11SRC_URI = "file://usb-gether \
12 file://COPYING.GPL"
13S = "${WORKDIR}"
14
15do_install() {
16 install -d ${D}${sysconfdir}
17 install -d ${D}${sysconfdir}/init.d
18 install usb-gether ${D}${sysconfdir}/init.d
19}
20
21inherit update-rc.d allarch
22
23INITSCRIPT_NAME = "usb-gether"
24INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."