summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
deleted file mode 100644
index eabf680ec6..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
4SECTION = "bootloader"
5
6# This revision corresponds to the tag "v2014.07"
7# We use the revision in order to avoid having to fetch it from the
8# repo during parse
9SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
10
11PV = "v2014.07+git${SRCPV}"
12
13SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
18
19do_compile () {
20 # Make sure the recompile is OK
21 rm -f ${B}/tools/.depend
22
23 make HOSTCC="${BUILD_CC}" HOSTLD="${BUILD_LD}" HOSTLDFLAGS="${BUILD_LDFLAGS}" HOSTSTRIP=true dot-config=0 scripts_basic
24 sed 's/^tools-only: scripts_basic /tools-only: /' -i Makefile
25 oe_runmake tools-only
26}
27
28do_install () {
29 install -d ${D}${bindir}
30 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
31 ln -sf uboot-mkimage ${D}${bindir}/mkimage
32}
33
34BBCLASSEXTEND = "native nativesdk"