summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
index 0108e0059f..a1b1db9555 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -1,17 +1,18 @@
1DESCRIPTION = "U-boot bootloader mkimage tool" 1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \ 3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4 file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
5SECTION = "bootloader" 4SECTION = "bootloader"
6 5
7SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2" 6# This revision corresponds to the tag "v2013.07"
7# We use the revision in order to avoid having to fetch it from the
8# repo during parse
9SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
8 10
9SRC_URI[md5sum] = "8445162690052e6afd4b8f87af2bb557" 11PV = "v2013.07+git${SRCPV}"
10SRC_URI[sha256sum] = "2bbd440c1b29928d230604eac372fda5152d3ae23f52b1910c77fc5bf531250b"
11 12
12S = "${WORKDIR}/u-boot-${PV}" 13SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
13 14
14BBCLASSEXTEND = "native nativesdk" 15S = "${WORKDIR}/git"
15 16
16EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true' 17EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
17 18
@@ -25,3 +26,4 @@ do_install () {
25 ln -sf uboot-mkimage ${D}${bindir}/mkimage 26 ln -sf uboot-mkimage ${D}${bindir}/mkimage
26} 27}
27 28
29BBCLASSEXTEND = "native nativesdk"