summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
index a626c9599a..9a304c8c5d 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
@@ -32,4 +32,16 @@ do_install () {
32 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config 32 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
33} 33}
34 34
35do_install_class-cross () {
36 install -d ${D}${bindir_cross}
37 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
38 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
39}
40
41SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
42uboot_fw_utils_cross() {
43 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
44}
45
35PACKAGE_ARCH = "${MACHINE_ARCH}" 46PACKAGE_ARCH = "${MACHINE_ARCH}"
47BBCLASSEXTEND = "cross"