summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb')
-rw-r--r--meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb b/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
new file mode 100644
index 0000000000..613e3161fb
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "U-Boot libraries and tools to access environment"
2
3DESCRIPTION = "This package contains tools and libraries to read \
4and modify U-Boot environment. \
5It provides a hardware-independent replacement for fw_printenv/setenv utilities \
6provided by U-Boot"
7
8HOMEPAGE = "https://github.com/sbabic/libubootenv"
9LICENSE = "LGPL-2.1"
10LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "libs"
12
13SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
14SRCREV = "824551ac77bab1d0f7ae34d7a7c77b155240e754"
15
16S = "${WORKDIR}/git"
17
18inherit uboot-config cmake lib_package
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
21
22DEPENDS = "zlib"
23PROVIDES += "u-boot-fw-utils"
24RPROVIDES_${PN}-bin += "u-boot-fw-utils"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28RRECOMMENDS_${PN}-bin_append_class-target = " u-boot-default-env"
29
30BBCLASSEXTEND = "native"