summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_2.06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.06.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_2.06.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.06.bb b/meta/recipes-bsp/grub/grub_2.06.bb
index d4e09faa40..05d462785c 100644
--- a/meta/recipes-bsp/grub/grub_2.06.bb
+++ b/meta/recipes-bsp/grub/grub_2.06.bb
@@ -1,24 +1,24 @@
1require grub2.inc 1require grub2.inc
2 2
3RDEPENDS_${PN}-common += "${PN}-editenv" 3RDEPENDS:${PN}-common += "${PN}-editenv"
4RDEPENDS_${PN} += "${PN}-common" 4RDEPENDS:${PN} += "${PN}-common"
5RDEPENDS_${PN}_class-native = "" 5RDEPENDS:${PN}:class-native = ""
6 6
7RPROVIDES_${PN}-editenv += "${PN}-efi-editenv" 7RPROVIDES:${PN}-editenv += "${PN}-efi-editenv"
8 8
9PROVIDES_append_class-native = " grub-efi-native" 9PROVIDES:append:class-native = " grub-efi-native"
10 10
11PACKAGES =+ "${PN}-editenv ${PN}-common" 11PACKAGES =+ "${PN}-editenv ${PN}-common"
12FILES_${PN}-editenv = "${bindir}/grub-editenv" 12FILES:${PN}-editenv = "${bindir}/grub-editenv"
13FILES_${PN}-common = " \ 13FILES:${PN}-common = " \
14 ${bindir} \ 14 ${bindir} \
15 ${sysconfdir} \ 15 ${sysconfdir} \
16 ${sbindir} \ 16 ${sbindir} \
17 ${datadir}/grub \ 17 ${datadir}/grub \
18" 18"
19ALLOW_EMPTY_${PN} = "1" 19ALLOW_EMPTY:${PN} = "1"
20 20
21do_install_append () { 21do_install:append () {
22 # Avoid conflicts with the EFI package for systems such as arm64 where we 22 # Avoid conflicts with the EFI package for systems such as arm64 where we
23 # need to build grub and grub-efi but only EFI is supported by removing EFI 23 # need to build grub and grub-efi but only EFI is supported by removing EFI
24 # from this package. 24 # from this package.
@@ -35,7 +35,7 @@ do_install_append () {
35 {} + 35 {} +
36} 36}
37 37
38INSANE_SKIP_${PN} = "arch" 38INSANE_SKIP:${PN} = "arch"
39INSANE_SKIP_${PN}-dbg = "arch" 39INSANE_SKIP:${PN}-dbg = "arch"
40 40
41BBCLASSEXTEND = "native nativesdk" 41BBCLASSEXTEND = "native nativesdk"