summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/efivar/efivar_39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/efivar/efivar_39.bb')
-rw-r--r--meta/recipes-bsp/efivar/efivar_39.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/efivar/efivar_39.bb b/meta/recipes-bsp/efivar/efivar_39.bb
new file mode 100644
index 0000000000..aab319be91
--- /dev/null
+++ b/meta/recipes-bsp/efivar/efivar_39.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
5LICENSE = "LGPL-2.1-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
12 "
13SRCREV = "c47820c37ac26286559ec004de07d48d05f3308c"
14PV .= "+39+git"
15
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20export CCLD_FOR_BUILD = "${BUILD_CCLD}"
21
22do_compile() {
23 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
24}
25
26do_install() {
27 oe_runmake install DESTDIR=${D}
28}
29
30BBCLASSEXTEND = "native"
31
32RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
33
34CLEANBROKEN = "1"