summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/efivar/efivar_37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/efivar/efivar_37.bb')
-rw-r--r--meta/recipes-bsp/efivar/efivar_37.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-bsp/efivar/efivar_37.bb b/meta/recipes-bsp/efivar/efivar_37.bb
deleted file mode 100644
index 5bf121ff6e..0000000000
--- a/meta/recipes-bsp/efivar/efivar_37.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git \
11 file://determinism.patch \
12 file://no-werror.patch"
13SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10"
14
15S = "${WORKDIR}/git"
16
17inherit pkgconfig
18
19export CCLD_FOR_BUILD = "${BUILD_CCLD}"
20
21# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
22# enforce BFD.
23LDFLAGS += "-fuse-ld=bfd"
24
25do_compile_prepend() {
26 # Remove when https://github.com/rhboot/efivar/issues/130 is fixed
27 oe_runmake \
28 CFLAGS="${BUILD_CFLAGS}" \
29 LDFLAGS="${BUILD_LDFLAGS}" \
30 -C src makeguids
31}
32
33do_install() {
34 oe_runmake install DESTDIR=${D}
35}
36
37BBCLASSEXTEND = "native"
38
39RRECOMMENDS_${PN}_class-target = "kernel-module-efivarfs"
40
41CLEANBROKEN = "1"