summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/efibootmgr/efibootmgr_18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/efibootmgr/efibootmgr_18.bb')
-rw-r--r--meta/recipes-bsp/efibootmgr/efibootmgr_18.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/efibootmgr/efibootmgr_18.bb b/meta/recipes-bsp/efibootmgr/efibootmgr_18.bb
new file mode 100644
index 0000000000..fbd2f5dbc8
--- /dev/null
+++ b/meta/recipes-bsp/efibootmgr/efibootmgr_18.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhboot/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "efivar popt"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https;branch=main"
14SRCREV = "c3f9f0534e32158f62c43564036878b93b9e0fd6"
15
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20# The directory under the ESP that the default bootloader is found in. When
21# wic uses a subdirectory, this should use the same one too.
22EFIDIR ?= "/"
23
24EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'"
25
26CFLAGS += " -Wno-error"
27
28do_install () {
29 oe_runmake install DESTDIR="${D}"
30}
31
32CLEANBROKEN = "1"