summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/alsa-state/alsa-state.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/alsa-state/alsa-state.bb')
-rw-r--r--meta/recipes-bsp/alsa-state/alsa-state.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-bsp/alsa-state/alsa-state.bb b/meta/recipes-bsp/alsa-state/alsa-state.bb
index bd7f610f46..099fbd3b9d 100644
--- a/meta/recipes-bsp/alsa-state/alsa-state.bb
+++ b/meta/recipes-bsp/alsa-state/alsa-state.bb
@@ -21,7 +21,8 @@ SRC_URI = "\
21 file://alsa-state-init \ 21 file://alsa-state-init \
22" 22"
23 23
24S = "${WORKDIR}" 24S = "${WORKDIR}/sources"
25UNPACKDIR = "${S}"
25 26
26# As the recipe doesn't inherit systemd.bbclass, we need to set this variable 27# As the recipe doesn't inherit systemd.bbclass, we need to set this variable
27# manually to avoid unnecessary postinst/preinst generated. 28# manually to avoid unnecessary postinst/preinst generated.
@@ -38,15 +39,15 @@ INITSCRIPT_PARAMS = "start 39 S . stop 31 0 6 ."
38do_install() { 39do_install() {
39 # Only install the init script when 'sysvinit' is in DISTRO_FEATURES. 40 # Only install the init script when 'sysvinit' is in DISTRO_FEATURES.
40 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then 41 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
41 sed -i -e "s:#STATEDIR#:${localstatedir}/lib/alsa:g" ${WORKDIR}/alsa-state-init 42 sed -i -e "s:#STATEDIR#:${localstatedir}/lib/alsa:g" ${S}/alsa-state-init
42 install -d ${D}${sysconfdir}/init.d 43 install -d ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/alsa-state-init ${D}${sysconfdir}/init.d/alsa-state 44 install -m 0755 ${S}/alsa-state-init ${D}${sysconfdir}/init.d/alsa-state
44 fi 45 fi
45 46
46 install -d ${D}/${localstatedir}/lib/alsa 47 install -d ${D}/${localstatedir}/lib/alsa
47 install -d ${D}${sysconfdir} 48 install -d ${D}${sysconfdir}
48 install -m 0644 ${WORKDIR}/asound.conf ${D}${sysconfdir} 49 install -m 0644 ${S}/asound.conf ${D}${sysconfdir}
49 install -m 0644 ${WORKDIR}/*.state ${D}${localstatedir}/lib/alsa 50 install -m 0644 ${S}/*.state ${D}${localstatedir}/lib/alsa
50} 51}
51 52
52PACKAGES += "alsa-states" 53PACKAGES += "alsa-states"