summaryrefslogtreecommitdiffstats
path: root/meta/packages/webkit/files/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/webkit/files/configure.ac')
-rw-r--r--meta/packages/webkit/files/configure.ac56
1 files changed, 33 insertions, 23 deletions
diff --git a/meta/packages/webkit/files/configure.ac b/meta/packages/webkit/files/configure.ac
index 64f32dc689..3ab2baffb8 100644
--- a/meta/packages/webkit/files/configure.ac
+++ b/meta/packages/webkit/files/configure.ac
@@ -263,11 +263,19 @@ AC_ARG_ENABLE(cross_document_messaging,
263 [],[enable_cross_document_messaging="yes"]) 263 [],[enable_cross_document_messaging="yes"])
264AC_MSG_RESULT([$enable_cross_document_messaging]) 264AC_MSG_RESULT([$enable_cross_document_messaging])
265 265
266# check whether to enable HTML5 client-side session and persitent storage support
267AC_MSG_CHECKING([whether to enable HTML5 client-side session and persistent storage support])
268AC_ARG_ENABLE(dom_storage,
269 AC_HELP_STRING([--enable-dom-storage],
270 [enable HTML5 client-side session and persistent storage support [default=no]]),
271 [],[enable_dom_storage="no"])
272AC_MSG_RESULT([$enable_dom_storage])
273
266# check whether to build with database support 274# check whether to build with database support
267AC_MSG_CHECKING([whether to enable HTML5 client-side storage support]) 275AC_MSG_CHECKING([whether to enable HTML5 client-side database storage support])
268AC_ARG_ENABLE(database, 276AC_ARG_ENABLE(database,
269 AC_HELP_STRING([--enable-database], 277 AC_HELP_STRING([--enable-database],
270 [enable HTML5 client-side storage support [default=yes]]), 278 [enable HTML5 client-side database storage support [default=yes]]),
271 [],[enable_database="yes"]) 279 [],[enable_database="yes"])
272AC_MSG_RESULT([$enable_database]) 280AC_MSG_RESULT([$enable_database])
273 281
@@ -498,6 +506,7 @@ AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
498# WebKit feature conditionals 506# WebKit feature conditionals
499AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"]) 507AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
500AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"]) 508AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"])
509AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
501AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"]) 510AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
502AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"]) 511AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
503AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"]) 512AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
@@ -526,27 +535,28 @@ echo "
526WebKit was configured with the following options: 535WebKit was configured with the following options:
527 536
528Build configuration: 537Build configuration:
529 Enable debugging (slow) : $enable_debug 538 Enable debugging (slow) : $enable_debug
530 Code coverage support : $enable_coverage 539 Code coverage support : $enable_coverage
531 Unicode backend : $unicode_backend 540 Unicode backend : $unicode_backend
532 HTTP backend : $with_http_backend 541 HTTP backend : $with_http_backend
533 Font backend : $with_font_backend 542 Font backend : $with_font_backend
534 Optimized memory allocator : $enable_fast_malloc 543 Optimized memory allocator : $enable_fast_malloc
535Features: 544Features:
536 HTML5 cross-document messaging : $enable_cross_document_messaging 545 HTML5 cross-document messaging : $enable_cross_document_messaging
537 HTML5 client-side storage support : $enable_database 546 HTML5 client-side session and persistent storage support : $enable_dom_storage
538 HTML5 video element support : $enable_video 547 HTML5 client-side database storage support : $enable_database
539 Icon database support : $enable_icon_database 548 HTML5 video element support : $enable_video
540 SVG support : $enable_svg 549 Icon database support : $enable_icon_database
541 SVG animation support : $enable_svg_animation 550 SVG support : $enable_svg
542 SVG filters support : $enable_svg_filters 551 SVG animation support : $enable_svg_animation
543 SVG fonts support : $enable_svg_fonts 552 SVG filters support : $enable_svg_filters
544 SVG foreign object support : $enable_svg_foreign_object 553 SVG fonts support : $enable_svg_fonts
545 SVG as image support : $enable_svg_as_image 554 SVG foreign object support : $enable_svg_foreign_object
546 SVG use element support : $enable_svg_use_element 555 SVG as image support : $enable_svg_as_image
547 XPATH support : $enable_xpath 556 SVG use element support : $enable_svg_use_element
548 XSLT support : $enable_xslt 557 XPATH support : $enable_xpath
558 XSLT support : $enable_xslt
549GTK+ configuration: 559GTK+ configuration:
550 GDK target : $with_target 560 GDK target : $with_target
551 Hildon UI extensions : $with_hildon 561 Hildon UI extensions : $with_hildon
552" 562"