summaryrefslogtreecommitdiffstats
path: root/meta/packages/uclibc/uclibc_0.9.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/uclibc/uclibc_0.9.29.bb')
-rw-r--r--meta/packages/uclibc/uclibc_0.9.29.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/uclibc/uclibc_0.9.29.bb b/meta/packages/uclibc/uclibc_0.9.29.bb
new file mode 100644
index 0000000000..293a00ed55
--- /dev/null
+++ b/meta/packages/uclibc/uclibc_0.9.29.bb
@@ -0,0 +1,32 @@
1# UCLIBC_BASE should be the latest released revision of uclibc (that way
2# the config files will typically be correct!) uclibc-cvs takes precedence
3# over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
4# try removing it
5#
6# UCLIBC_BASE can be set in a distro file, but whether this works depends
7# on whether the base patches apply to the selected (SRCDATE) svn release.
8#
9UCLIBC_BASE ?= "0.9.29"
10PR = "r3"
11
12require uclibc.inc
13
14PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
15
16SRC_URI += "file://uClibc.machine file://uClibc.distro"
17# mmap-unsigned-shift_bugid1303.patch
18# http://uclibc.org/lists/uclibc-cvs/2007-May/011360.html;patch=1"
19
20#recent versions uclibc require real kernel headers
21PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23#as stated above, uclibc needs real kernel-headers
24#however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
25KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
26
27SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
28
29S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"
30
31LEAD_SONAME = "libc.so"
32