summaryrefslogtreecommitdiffstats
path: root/meta/packages/uboot/uboot-gta01_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/uboot/uboot-gta01_svn.bb')
-rw-r--r--meta/packages/uboot/uboot-gta01_svn.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/packages/uboot/uboot-gta01_svn.bb b/meta/packages/uboot/uboot-gta01_svn.bb
new file mode 100644
index 0000000000..d026efccc1
--- /dev/null
+++ b/meta/packages/uboot/uboot-gta01_svn.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "U-boot bootloader w/ Neo1973 (GTA01) support"
2AUTHOR = "Harald Welte <laforge@openmoko.org>"
3LICENSE = "GPL"
4SECTION = "bootloader"
5PRIORITY = "optional"
6PV = "1.2.0+svn${SRCDATE}"
7PR = "r3"
8
9PROVIDES = "virtual/bootloader"
10S = "${WORKDIR}/git"
11
12SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git \
13 svn://svn.openmoko.org/trunk/src/target/u-boot;module=patches;proto=http \
14 file://fix-arm920t-eabi.patch;patch=1"
15
16EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
17TARGET_LDFLAGS = ""
18UBOOT_MACHINES = "gta01v3 gta01v4 gta01bv2 gta01bv3"
19
20do_quilt() {
21 mv ${WORKDIR}/patches ${S}/patches
22 cd ${S}
23 quilt push -av
24 rm -Rf patches .pc
25}
26
27do_compile () {
28 chmod +x board/neo1973/split_by_variant.sh
29 for type in ram nand
30 do
31 for mach in ${UBOOT_MACHINES}
32 do
33 oe_runmake ${mach}_config
34 oe_runmake clean
35 if [ ${type} == "ram" ]; then
36 echo 'PLATFORM_RELFLAGS += -DBUILD_FOR_RAM' >> board/neo1973/config.tmp
37 fi
38 oe_runmake all
39 mv u-boot.bin u-boot_${mach}_${type}.bin
40 done
41 done
42}
43
44do_deploy () {
45 install -d ${DEPLOY_DIR_IMAGE}
46 for type in nand ram
47 do
48 for mach in ${UBOOT_MACHINES}
49 do
50 install ${S}/u-boot_${mach}_${type}.bin ${DEPLOY_DIR_IMAGE}/u-boot_${type}-${mach}-${DATETIME}.bin
51 done
52 done
53 install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
54}
55
56do_deploy[dirs] = "${S}"
57addtask deploy before do_build after do_compile
58addtask quilt before do_patch after do_unpack