summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu_0.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/qemu/qemu_0.12.0.bb')
-rw-r--r--meta/packages/qemu/qemu_0.12.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu_0.12.0.bb b/meta/packages/qemu/qemu_0.12.0.bb
new file mode 100644
index 0000000000..e4f8a2ca1d
--- /dev/null
+++ b/meta/packages/qemu/qemu_0.12.0.bb
@@ -0,0 +1,51 @@
1LICENSE = "GPL"
2DEPENDS = "zlib"
3PR = "r9"
4
5FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
6FILESDIR = "${WORKDIR}"
7
8SRC_URI = "\
9 http://download.savannah.gnu.org/releases/qemu/qemu-0.12.0.tar.gz \
10 file://workaround_bad_futex_headers.patch;patch=1 \
11 file://qemu-git-qemugl-host.patch;patch=1 \
12 file://no-strip.patch;patch=1 \
13 file://fix-dirent.patch;patch=1 \
14 file://fix-nogl.patch;patch=1 \
15 file://qemugl-allow-glxcontext-release.patch;patch=1"
16
17S = "${WORKDIR}/qemu-${PV}"
18
19EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls"
20#EXTRA_OECONF += "--disable-sdl"
21
22inherit autotools
23
24# For our gl powered QEMU you need libGL and SDL headers
25do_configure_prepend_virtclass-native() {
26 libgl='no'
27 libsdl='no'
28
29 test -e /usr/lib/libGL.so -a -e /usr/lib/libGLU.so && libgl='yes'
30 test -e /usr/lib64/libGL.so -a -e /usr/lib64/libGLU.so && libgl='yes'
31
32 test -e /usr/lib/pkgconfig/sdl.pc -o -e /usr/lib64/pkgconfig/sdl.pc && libsdl='yes'
33
34 if [ "$libsdl" != 'yes' -o "$libgl" != 'yes' ]; then
35 echo "You need libGL.so and libGLU.so to exist in your library path and the development headers for SDL installed to build qemu-native.
36 Ubuntu package names are: libgl1-mesa-dev, libglu1-mesa-dev and libsdl1.2-dev"
37 exit 1;
38 fi
39}
40
41do_configure() {
42 ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
43 chmod a+x ${S}/target-i386/beginend_funcs.sh
44}
45
46SRC_URI_append_virtclass-nativesdk = " file://glflags.patch;patch=1"
47DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk qemugl-nativesdk"
48RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
49EXTRA_OECONF_virtclass-nativesdk = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-vnc-tls --cc=${HOST_PREFIX}gcc"
50
51BBCLASSEXTEND = "native nativesdk"