summaryrefslogtreecommitdiffstats
path: root/meta/packages/pth/pth_2.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pth/pth_2.0.7.bb')
-rw-r--r--meta/packages/pth/pth_2.0.7.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/pth/pth_2.0.7.bb b/meta/packages/pth/pth_2.0.7.bb
new file mode 100644
index 0000000000..cdb0cf2cb1
--- /dev/null
+++ b/meta/packages/pth/pth_2.0.7.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "GNU Portable Threads"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "GPL LGPL FDL"
5
6SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
7
8PARALLEL_MAKE=""
9
10inherit autotools
11
12do_configure() {
13 gnu-configize
14 oe_runconf
15}
16
17do_stage() {
18 oe_libinstall -so libpth ${STAGING_LIBDIR}
19
20 install -d ${STAGING_INCDIR}/
21 for X in pth.h
22 do
23 install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
24 done
25
26 install -d ${STAGING_DATADIR}/aclocal
27 install pth.m4 ${STAGING_DATADIR}/aclocal/
28}