summaryrefslogtreecommitdiffstats
path: root/meta/packages/pcmanfm/files/owl-window-menu.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pcmanfm/files/owl-window-menu.patch')
-rw-r--r--meta/packages/pcmanfm/files/owl-window-menu.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/packages/pcmanfm/files/owl-window-menu.patch b/meta/packages/pcmanfm/files/owl-window-menu.patch
new file mode 100644
index 0000000000..31eba8683b
--- /dev/null
+++ b/meta/packages/pcmanfm/files/owl-window-menu.patch
@@ -0,0 +1,56 @@
1Index: pcmanfm-0.3.2-beta/configure.in
2===================================================================
3--- pcmanfm-0.3.2-beta.orig/configure.in 2007-04-26 09:09:33.000000000 +0100
4+++ pcmanfm-0.3.2-beta/configure.in 2007-04-26 09:12:41.000000000 +0100
5@@ -15,6 +15,12 @@
6 libstartup-notification-1.0"
7
8 PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
9+
10+OWL_CFLAGS=""
11+OWL_LIBS="-lowl"
12+PACKAGE_CFLAGS="$PACKAGE_CFLAGS $OWL_CFLAGS"
13+PACKAGE_LIBS="$PACKAGE_LIBS $OWL_LIBS"
14+
15 AC_SUBST(PACKAGE_CFLAGS)
16 AC_SUBST(PACKAGE_LIBS)
17
18Index: pcmanfm-0.3.2-beta/src/main-window.c
19===================================================================
20--- pcmanfm-0.3.2-beta.orig/src/main-window.c 2007-04-26 09:09:15.000000000 +0100
21+++ pcmanfm-0.3.2-beta/src/main-window.c 2007-04-26 09:10:51.000000000 +0100
22@@ -414,9 +414,7 @@
23 main_window->splitter_pos = appSettings.splitterPos;
24
25 /* Create menu bar */
26- main_window->menu_bar = gtk_menu_bar_new ();
27- gtk_box_pack_start ( GTK_BOX ( main_window->main_vbox ),
28- main_window->menu_bar, FALSE, FALSE, 0 );
29+ main_window->menu_bar = gtk_menu_new ();
30
31 main_window->accel_group = gtk_accel_group_new ();
32 fm_side_pane_menu[ 0 ].ret = ( GtkWidget** ) & main_window->open_side_pane_menu;
33Index: pcmanfm-0.3.2-beta/src/main.c
34===================================================================
35--- pcmanfm-0.3.2-beta.orig/src/main.c 2007-04-26 09:09:15.000000000 +0100
36+++ pcmanfm-0.3.2-beta/src/main.c 2007-04-26 09:21:40.000000000 +0100
37@@ -32,6 +32,8 @@
38 #include "glade-support.h"
39 #include "settings.h"
40
41+#include "owlwindowmenu.h"
42+
43 static char* init_path = NULL;
44
45 static int sock;
46@@ -171,6 +173,10 @@
47 gtk_window_set_default_size( GTK_WINDOW( main_window ),
48 appSettings.width, appSettings.height );
49 gtk_widget_show ( GTK_WIDGET( main_window ) );
50+ gtk_widget_show_all (main_window->menu_bar);
51+ owl_set_window_menu (GTK_WINDOW(main_window),
52+ GTK_MENU(main_window->menu_bar));
53+
54 return main_window;
55 }
56 #if 0