summaryrefslogtreecommitdiffstats
path: root/meta/packages/pciutils/pciutils-2.2.4/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pciutils/pciutils-2.2.4/configure.patch')
-rw-r--r--meta/packages/pciutils/pciutils-2.2.4/configure.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/packages/pciutils/pciutils-2.2.4/configure.patch b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
new file mode 100644
index 0000000000..78d113c498
--- /dev/null
+++ b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
@@ -0,0 +1,40 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6Index: pciutils-2.2.4/lib/configure
7===================================================================
8--- pciutils-2.2.4.orig/lib/configure 2006-09-09 13:06:10.000000000 +0200
9+++ pciutils-2.2.4/lib/configure 2006-10-31 11:52:13.000000000 +0100
10@@ -12,15 +12,15 @@
11 echo_n "Configuring libpci for your system..."
12 idsdir=${1:-/usr/share}
13 version=${2:-0.0}
14-sys=`uname -s`
15-rel=`uname -r`
16+sys=${3:-`uname -s`}
17+rel=${4:-`uname -r`}
18 if [ "$sys" = "AIX" -a -x /usr/bin/oslevel -a -x /usr/sbin/lsattr ]
19 then
20 rel=`/usr/bin/oslevel`
21 proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
22 cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
23 else
24- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`
25+ cpu=${5:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`}
26 fi
27 if [ "$sys" = "GNU/kFreeBSD" ]
28 then
29@@ -34,6 +34,11 @@
30 echo " $host $rel"
31 zlib=$5
32
33+if [ "$host" = "linux--gnueabi" ]
34+then
35+ sys=linux
36+fi
37+
38 c=config.h
39 m=config.mk
40 echo >$c "#define PCI_ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"