summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux-libc-headers
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/linux-libc-headers')
-rw-r--r--meta/packages/linux-libc-headers/files/keyboard.patch78
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/3477-1.patch43
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/asm-arch-irqs.patch19
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netdevice.patch11
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netfilter_ipv4.patch31
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-rtc.patch11
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch45
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb65
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb80
9 files changed, 383 insertions, 0 deletions
diff --git a/meta/packages/linux-libc-headers/files/keyboard.patch b/meta/packages/linux-libc-headers/files/keyboard.patch
new file mode 100644
index 0000000000..7df00418b1
--- /dev/null
+++ b/meta/packages/linux-libc-headers/files/keyboard.patch
@@ -0,0 +1,78 @@
1--- kernel/include/linux/keyboard.h 2004-01-17 23:04:30.000000000 +0000
2+++ kernel/include/linux/keyboard.h 2004-08-30 12:49:41.000000000 +0100
3@@ -37,6 +44,8 @@
4 #define KT_ASCII 9
5 #define KT_LOCK 10
6 #define KT_SLOCK 12
7+#define KT_X 13 /* A few useful symbols from the base X Keysym set, that go with... */
8+#define KT_XF 14 /* The XFree86 Internet multimedia and PDA keyboard symbols */
9
10 #define K(t,v) (((t)<<8)|(v))
11 #define KTYP(x) ((x) >> 8)
12@@ -421,4 +430,66 @@
13 #define NR_LOCK 8
14
15 #define MAX_DIACR 256
16+
17+/*
18+ * modifications to this section of this list should be coordinated with
19+ * the X Window System keysym list; life is much easier that way
20+ *
21+ */
22+
23+/* These don't correspond identically. */
24+#define K_XMENU K(KT_X, 0x1)
25+#define K_XTELEPHONE K(KT_X, 0x2)
26+
27+/*
28+ * XFree86 vendor specific keysyms.
29+ *
30+ * These map to XFree86 X keysym range is 0x1008FF01 - 0x1008FFFF;
31+ * for simplicity's sake, we'll define a simple identity mapping for these.
32+ *
33+ * Please coordinate changes here with XFree86.org, so this simple
34+ * identity mapping can be maintained (and old code "just works").
35+ *
36+ * Keys found on some "Internet" keyboards.
37+ */
38+#define K_XFSTANDBY K(KT_XF,0x10)
39+#define K_XFAUDIOLOWERVOLUME K(KT_XF,0x11)
40+#define K_XFAUDIOMUTE K(KT_XF,0x12)
41+#define K_XFAUDIORAISEVOLUME K(KT_XF,0x13)
42+#define K_XFAUDIOPLAY K(KT_XF,0x14)
43+#define K_XFAUDIOSTOP K(KT_XF,0x15)
44+#define K_XFAUDIOPREV K(KT_XF,0x16)
45+#define K_XFAUDIONEXT K(KT_XF,0x17)
46+#define K_XFHOMEPAGE K(KT_XF,0x18)
47+#define K_XFMAIL K(KT_XF,0x19)
48+#define K_XFSTART K(KT_XF,0x1A)
49+#define K_XFSEARCH K(KT_XF,0x1B)
50+#define K_XFAUDIORECORD K(KT_XF,0x1C)
51+
52+/* These are sometimes found on PDA's (e.g. Palm, PocketPC or elsewhere) */
53+#define K_XFCALCULATOR K(KT_XF,0x1D)
54+#define K_XFMEMO K(KT_XF,0x1E)
55+#define K_XFTODOLIST K(KT_XF,0x1F)
56+#define K_XFCALENDAR K(KT_XF,0x20)
57+#define K_XFPOWERDOWN K(KT_XF,0x21)
58+#define K_XFCONTRASTADJUST K(KT_XF,0x22)
59+#define K_XFROCKERUP K(KT_XF,0x23)
60+#define K_XFROCKERDOWN K(KT_XF,0x24)
61+#define K_XFROCKERENTER K(KT_XF,0x25)
62+
63+/* Some more "Internet" keyboard symbols */
64+#define K_XFBACK K(KT_XF,0x26)
65+#define K_XFFORWARD K(KT_XF,0x27)
66+#define K_XFSTOP K(KT_XF,0x28)
67+#define K_XFREFRESH K(KT_XF,0x29)
68+
69+/* Some more ... */
70+#define K_XFFAVORITES K(KT_XF,0x30)
71+#define K_XFAUDIOPAUSE K(KT_XF,0x31)
72+#define K_XFAUDIOMEDIA K(KT_XF,0x32)
73+#define K_XFMYCOMPUTER K(KT_XF,0x33)
74+#define K_XFVENDORHOME K(KT_XF,0x34)
75+#define K_XFLIGHTBULB K(KT_XF,0x35)
76+#define K_XFSHOP K(KT_XF,0x36)
77+
78 #endif
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/3477-1.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/3477-1.patch
new file mode 100644
index 0000000000..1b207b3cd9
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/3477-1.patch
@@ -0,0 +1,43 @@
1From: Nicolas Pitre <nico@cam.org>
2Date: Sat, 15 Apr 2006 15:10:43 +0000 (+0100)
3Subject: [ARM] 3477/1: ARM EABI: undefine removed syscalls
4X-Git-Url: http://git.infradead.org/?p=mtd-2.6.git;a=commitdiff;h=463b158aab247b600e4e93614b7b8f42a66331c9
5
6[ARM] 3477/1: ARM EABI: undefine removed syscalls
7
8Patch from Nicolas Pitre
9
10Avoid confusion for libraries assuming that a given syscall is available
11when corresponding symbol is defined.
12
13Signed-off-by: Nicolas Pitre <nico@cam.org>
14Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
15---
16
17--- a/include/asm-arm/unistd.h
18+++ b/include/asm-arm/unistd.h
19@@ -360,6 +360,24 @@
20 #define __ARM_NR_usr32 (__ARM_NR_BASE+4)
21 #define __ARM_NR_set_tls (__ARM_NR_BASE+5)
22
23+/*
24+ * The following syscalls are obsolete and no longer available for EABI.
25+ */
26+#if defined(__ARM_EABI__)
27+#undef __NR_time
28+#undef __NR_umount
29+#undef __NR_stime
30+#undef __NR_alarm
31+#undef __NR_utime
32+#undef __NR_getrlimit
33+#undef __NR_select
34+#undef __NR_readdir
35+#undef __NR_mmap
36+#undef __NR_socketcall
37+#undef __NR_syscall
38+#undef __NR_ipc
39+#endif
40+
41 #define __sys2(x) #x
42 #define __sys1(x) __sys2(x)
43
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/asm-arch-irqs.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/asm-arch-irqs.patch
new file mode 100644
index 0000000000..4785275db4
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/asm-arch-irqs.patch
@@ -0,0 +1,19 @@
1--- linux-libc-headers-2.6.15.99/include/asm-arm/arch-ebsa285/irqs.h.orig 2006-03-19 17:01:59.000000000 +0100
2+++ linux-libc-headers-2.6.15.99/include/asm-arm/arch-ebsa285/irqs.h 2006-03-19 17:02:50.000000000 +0100
3@@ -8,7 +8,6 @@
4 * 20-Jan-1998 RMK Started merge of EBSA286, CATS and NetWinder
5 * 01-Feb-1999 PJB ISA IRQs start at 0 not 16
6 */
7-#include <asm/mach-types.h>
8
9 #define NR_IRQS 36
10 #define NR_DC21285_IRQS 16
11@@ -92,7 +91,7 @@
12 #undef RTC_IRQ
13 #define RTC_IRQ IRQ_ISA_RTC_ALARM
14 #define I8042_KBD_IRQ IRQ_ISA_KEYBOARD
15-#define I8042_AUX_IRQ (machine_is_netwinder() ? IRQ_NETWINDER_PS2MOUSE : IRQ_ISA_PS2MOUSE)
16+#define I8042_AUX_IRQ IRQ_ISA_PS2MOUSE
17 #define IRQ_FLOPPYDISK IRQ_ISA_FLOPPY
18
19 #define irq_canonicalize(_i) (((_i) == IRQ_ISA_CASCADE) ? IRQ_ISA_2 : _i)
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netdevice.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netdevice.patch
new file mode 100644
index 0000000000..588aea4ba8
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netdevice.patch
@@ -0,0 +1,11 @@
1--- linux-libc-headers-2.6.15.99/include/linux/netdevice.h.orig 2006-04-29 14:10:39.245687500 +0200
2+++ linux-libc-headers-2.6.15.99/include/linux/netdevice.h 2006-04-29 14:11:08.819535750 +0200
3@@ -100,8 +100,6 @@
4 unsigned long tx_compressed;
5 };
6
7-extern int __init netdev_boot_setup(char *str);
8-
9 /* Media selection options. */
10 enum {
11 IF_PORT_UNKNOWN = 0,
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netfilter_ipv4.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netfilter_ipv4.patch
new file mode 100644
index 0000000000..f7f77af0de
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-netfilter_ipv4.patch
@@ -0,0 +1,31 @@
1iptables 1.3.3 assumes that ipt_scpt.h defines ELEMCOUNT, but ipt_scpt.h
2moved to ARRAY_SIZE (which would be defined in linux/kernel.h).
3The ip_conntrack_dir definition now resides in linux/netfilter/ip_conntrack_common.h
4
5--- linux-libc-headers-2.6.15.99/include/linux/netfilter_ipv4/ipt_sctp.h.orig 2006-03-20 22:03:04.000000000 +0100
6+++ linux-libc-headers-2.6.15.99/include/linux/netfilter_ipv4/ipt_sctp.h 2006-03-20 22:07:09.000000000 +0100
7@@ -7,6 +7,8 @@
8
9 #define IPT_SCTP_VALID_FLAGS 0x07
10
11+#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
12+#define ELEMCOUNT(x) (sizeof(x) / sizeof((x)[0]))
13
14 struct ipt_sctp_flag_info {
15 u_int8_t chunktype;
16--- linux-libc-headers-2.6.15.99/include/linux/netfilter_ipv4/ip_conntrack_tuple.h.orig 2006-03-20 21:51:10.000000000 +0100
17+++ linux-libc-headers-2.6.15.99/include/linux/netfilter_ipv4/ip_conntrack_tuple.h 2006-03-20 21:51:12.000000000 +0100
18@@ -89,13 +89,6 @@
19 (tuple)->dst.u.all = 0; \
20 } while (0)
21
22-enum ip_conntrack_dir
23-{
24- IP_CT_DIR_ORIGINAL,
25- IP_CT_DIR_REPLY,
26- IP_CT_DIR_MAX
27-};
28-
29 static inline int ip_ct_tuple_src_equal(const struct ip_conntrack_tuple *t1,
30 const struct ip_conntrack_tuple *t2)
31 {
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-rtc.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-rtc.patch
new file mode 100644
index 0000000000..36b80fb9d2
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-rtc.patch
@@ -0,0 +1,11 @@
1--- linux-libc-headers-2.6.15.99/include/linux/rtc.h.orig 2006-03-19 12:31:07.000000000 +0100
2+++ linux-libc-headers-2.6.15.99/include/linux/rtc.h 2006-03-19 12:31:14.000000000 +0100
3@@ -11,8 +11,6 @@
4 #ifndef _LINUX_RTC_H_
5 #define _LINUX_RTC_H_
6
7-#include <linux/interrupt.h>
8-
9 /*
10 * The struct used to pass data via the following ioctl. Similar to the
11 * struct tm in <time.h>, but it needs to be here so that the kernel
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch
new file mode 100644
index 0000000000..95335c99b6
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch
@@ -0,0 +1,45 @@
1--- linux-libc-headers-2.6.15.99/include/linux/videodev2.h.orig 2006-03-20 11:14:35.000000000 +0100
2+++ linux-libc-headers-2.6.15.99/include/linux/videodev2.h 2006-03-20 11:14:37.000000000 +0100
3@@ -15,7 +15,32 @@
4 */
5 #include <sys/time.h> /* need struct timeval */
6 #include <asm/types.h> /* needed __u64 */
7-
8+
9+#define OBSOLETE_OWNER 1 /* It will be removed for 2.6.15 */
10+#define HAVE_V4L2 1
11+
12+/*
13+ * Common stuff for both V4L1 and V4L2
14+ * Moved from videodev.h
15+ */
16+
17+#define VIDEO_MAX_FRAME 32
18+
19+#define VID_TYPE_CAPTURE 1 /* Can capture */
20+#define VID_TYPE_TUNER 2 /* Can tune */
21+#define VID_TYPE_TELETEXT 4 /* Does teletext */
22+#define VID_TYPE_OVERLAY 8 /* Overlay onto frame buffer */
23+#define VID_TYPE_CHROMAKEY 16 /* Overlay by chromakey */
24+#define VID_TYPE_CLIPPING 32 /* Can clip */
25+#define VID_TYPE_FRAMERAM 64 /* Uses the frame buffer memory */
26+#define VID_TYPE_SCALES 128 /* Scalable */
27+#define VID_TYPE_MONOCHROME 256 /* Monochrome only */
28+#define VID_TYPE_SUBCAPTURE 512 /* Can capture subareas of the image */
29+#define VID_TYPE_MPEG_DECODER 1024 /* Can decode MPEG streams */
30+#define VID_TYPE_MPEG_ENCODER 2048 /* Can encode MPEG streams */
31+#define VID_TYPE_MJPEG_DECODER 4096 /* Can decode MJPEG streams */
32+#define VID_TYPE_MJPEG_ENCODER 8192 /* Can encode MJPEG streams */
33+
34 /*
35 * M I S C E L L A N E O U S
36 */
37@@ -464,7 +489,7 @@
38 struct v4l2_clip
39 {
40 struct v4l2_rect c;
41- struct v4l2_clip __user *next;
42+ struct v4l2_clip *next;
43 };
44
45 struct v4l2_window
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
new file mode 100644
index 0000000000..2f471223e6
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -0,0 +1,65 @@
1SECTION = "devel"
2DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
3HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
4# license note from the package:
5# Linux-libc-headers are derived from linux kernel headers. For license of a
6# particular header, check it's content, and if copyright notice isn't present,
7# standard linux kernel license applies.
8# since we assume GPL for linux i think we can also assume it here
9LICENSE = "GPL"
10MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
11INHIBIT_DEFAULT_DEPS = "1"
12PR = "r2"
13
14SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
15 file://keyboard.patch;patch=1"
16
17S = "${WORKDIR}/linux-libc-headers-${PV}"
18
19do_configure () {
20 case ${TARGET_ARCH} in
21 alpha*) ARCH=alpha ;;
22 arm*) ARCH=arm ;;
23 cris*) ARCH=cris ;;
24 hppa*) ARCH=parisc ;;
25 i*86*) ARCH=i386 ;;
26 ia64*) ARCH=ia64 ;;
27 mips*) ARCH=mips ;;
28 m68k*) ARCH=m68k ;;
29 powerpc*) ARCH=ppc ;;
30 s390*) ARCH=s390 ;;
31 sh*) ARCH=sh ;;
32 sparc64*) ARCH=sparc64 ;;
33 sparc*) ARCH=sparc ;;
34 x86_64*) ARCH=x86_64 ;;
35 esac
36 if test ! -e include/asm-$ARCH; then
37 oefatal unable to create asm symlink in kernel headers
38 fi
39 cp -pPR "include/asm-$ARCH" "include/asm"
40 if test "$ARCH" = "arm"; then
41 cp -pPR include/asm/arch-ebsa285 include/asm/arch
42 elif test "$ARCH" = "sh"; then
43 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
44 cp -pPR include/asm/cpu/* include/asm
45 fi
46}
47
48do_stage () {
49 install -d ${STAGING_INCDIR}
50 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
51 cp -pfLR include/linux ${STAGING_INCDIR}/
52 cp -pfLR include/asm ${STAGING_INCDIR}/
53 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
54 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
55 install -d ${CROSS_DIR}/${TARGET_SYS}/include
56 cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
57 cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
58}
59
60do_install() {
61 install -d ${D}${includedir}
62 cp -pfLR include/linux ${D}${includedir}/
63 cp -pfLR include/asm ${D}${includedir}/
64}
65
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
new file mode 100644
index 0000000000..28926f0264
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
@@ -0,0 +1,80 @@
1SECTION = "devel"
2DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
3# This package is derived from the original linux-libc-headers at
4# http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
5# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
6# the official linux patches (where applicable) and then fixed up just
7# enough to build glibc-2.4. BEWARE!
8#
9# license note from the linux-libc-headers package:
10# Linux-libc-headers are derived from linux kernel headers. For license of a
11# particular header, check it's content, and if copyright notice isn't present,
12# standard linux kernel license applies.
13# since we assume GPL for linux i think we can also assume it here
14LICENSE = "GPL"
15DEFAULT_PREFERENCE = "-1"
16INHIBIT_DEFAULT_DEPS = "1"
17PR = "r4"
18
19SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2 \
20 file://keyboard.patch;patch=1 \
21 file://asm-arch-irqs.patch;patch=1 \
22 file://linux-netdevice.patch;patch=1 \
23 file://linux-netfilter_ipv4.patch;patch=1 \
24 file://linux-rtc.patch;patch=1 \
25 file://linux-videodev2.patch;patch=1 \
26 file://3477-1.patch;patch=1"
27
28S = "${WORKDIR}/linux-libc-headers-${PV}"
29
30do_configure () {
31 case ${TARGET_ARCH} in
32 alpha*) ARCH=alpha ;;
33 arm*) ARCH=arm ;;
34 cris*) ARCH=cris ;;
35 hppa*) ARCH=parisc ;;
36 i*86*) ARCH=i386 ;;
37 ia64*) ARCH=ia64 ;;
38 mips*) ARCH=mips ;;
39 m68k*) ARCH=m68k ;;
40 powerpc*) ARCH=ppc ;;
41 s390*) ARCH=s390 ;;
42 sh*) ARCH=sh ;;
43 sparc64*) ARCH=sparc64 ;;
44 sparc*) ARCH=sparc ;;
45 x86_64*) ARCH=x86_64 ;;
46 esac
47 if test ! -e include/asm-$ARCH; then
48 oefatal unable to create asm symlink in kernel headers
49 fi
50 rm "include/asm"
51 cp -pPR "include/asm-$ARCH" "include/asm"
52 if test "$ARCH" = "arm"; then
53 cp -pPR include/asm/arch-ebsa285 include/asm/arch
54 elif test "$ARCH" = "sh"; then
55 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
56 fi
57}
58
59do_stage () {
60 install -d ${STAGING_INCDIR}
61 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
62 cp -pfLR include/linux ${STAGING_INCDIR}/
63 cp -pfLR include/asm ${STAGING_INCDIR}/
64 cp -pfLR include/asm-generic ${STAGING_INCDIR}/
65 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
66 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
67 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm-generic
68 install -d ${CROSS_DIR}/${TARGET_SYS}/include
69 cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
70 cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
71 cp -pfLR include/asm-generic ${CROSS_DIR}/${TARGET_SYS}/include/
72}
73
74do_install() {
75 install -d ${D}${includedir}
76 cp -pfLR include/linux ${D}${includedir}/
77 cp -pfLR include/asm ${D}${includedir}/
78 cp -pfLR include/asm-generic ${D}${includedir}/
79}
80