summaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool/libtool/prefix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libtool/libtool/prefix.patch')
-rw-r--r--meta/packages/libtool/libtool/prefix.patch121
1 files changed, 121 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool/prefix.patch b/meta/packages/libtool/libtool/prefix.patch
new file mode 100644
index 0000000000..895be1f9b0
--- /dev/null
+++ b/meta/packages/libtool/libtool/prefix.patch
@@ -0,0 +1,121 @@
1Renames "libtool" -> "${TARGET_PREFIX}libtool" which makes sure
2it can't be confused with the host libtool.
3
4
5After discussions with RP Changed host_alias to build_alias
6at one place as it was causing man page building issue while
7cross compiling for different architectures.
8
9Date: 2010/06/28
10Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
11
12
13Index: libtool-2.2.10/libltdl/m4/libtool.m4
14===================================================================
15--- libtool-2.2.10.orig/libltdl/m4/libtool.m4
16+++ libtool-2.2.10/libltdl/m4/libtool.m4
17@@ -94,7 +94,8 @@ _LT_SET_OPTIONS([$0], [$1])
18 LIBTOOL_DEPS="$ltmain"
19
20 # Always use our own libtool.
21-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
22+LIBTOOL='$(SHELL) $(top_builddir)'
23+LIBTOOL="$LIBTOOL/${host_alias}-libtool"
24 AC_SUBST(LIBTOOL)dnl
25
26 _LT_SETUP
27@@ -201,7 +202,7 @@ aix3*)
28 esac
29
30 # Global variables:
31-ofile=libtool
32+ofile=${host_alias}-libtool
33 can_build_shared=yes
34
35 # All known linkers require a `.a' archive for static linking (except MSVC,
36Index: libtool-2.2.10/Makefile.am
37===================================================================
38--- libtool-2.2.10.orig/Makefile.am
39+++ libtool-2.2.10/Makefile.am
40@@ -31,7 +31,7 @@ AM_LDFLAGS =
41 DIST_SUBDIRS = .
42 EXTRA_DIST =
43
44-BUILT_SOURCES = libtool libtoolize
45+BUILT_SOURCES = $(host_alias)-libtool libtoolize
46
47 CLEANFILES =
48 MOSTLYCLEANFILES =
49@@ -65,7 +65,7 @@ rebuild = rebuild=:; $(timestamp); corre
50 ## ---------------- ##
51
52 # The libtool distributor and the standalone libtool script.
53-bin_SCRIPTS = libtoolize libtool
54+bin_SCRIPTS = libtoolize $(host_alias)-libtool
55
56 libtoolize: $(srcdir)/libtoolize.in $(top_builddir)/config.status
57 rm -f libtoolize.tmp libtoolize
58@@ -91,8 +91,8 @@ $(srcdir)/libtoolize.in: $(sh_files) lib
59 # We used to do this with a 'stamp-vcl' file, but non-gmake builds
60 # would rerun configure on every invocation, so now we manually
61 # check the version numbers from the build rule when necessary.
62-libtool: $(top_builddir)/config.status $(srcdir)/$(auxdir)/ltmain.sh ChangeLog
63- @target=libtool; $(rebuild); \
64+$(host_alias)-libtool: $(top_builddir)/config.status $(srcdir)/$(auxdir)/ltmain.sh ChangeLog
65+ @target=$(host_alias)-libtool; $(rebuild); \
66 if test -f "$$target"; then \
67 set dummy `./$$target --version | sed 1q`; actualver="$$5"; \
68 test "$$actualver" = "$$correctver" && rebuild=false; \
69@@ -101,8 +101,8 @@ libtool: $(top_builddir)/config.status $
70 case $$prereq in *ChangeLog);; *) rebuild=:;; esac; \
71 done; \
72 if $$rebuild; then \
73- echo $(SHELL) ./config.status $$target; \
74- cd $(top_builddir) && $(SHELL) ./config.status $$target; \
75+ echo $(SHELL) ./config.status libtool; \
76+ cd $(top_builddir) && $(SHELL) ./config.status libtool; \
77 fi
78
79 .PHONY: configure-subdirs
80@@ -147,7 +147,7 @@ EXTRA_DIST += bootstrap $(srcdir)/li
81 ChangeLog.2002 ChangeLog.2003 ChangeLog.2004 \
82 ChangeLog.2005 ChangeLog.2006 ChangeLog.2007 \
83 ChangeLog.2008 ChangeLog.2009
84-CLEANFILES += libtool libtoolize libtoolize.tmp \
85+CLEANFILES += $(host_alias)-libtool libtoolize libtoolize.tmp \
86 $(auxdir)/ltmain.tmp $(m4dir)/ltversion.tmp
87
88 ## We build ltversion.m4 here, instead of from config.status,
89@@ -337,7 +337,7 @@ update_mans = \
90 PATH=.$(PATH_SEPARATOR)$$PATH; export PATH; \
91 $(HELP2MAN) --output=$@
92 $(srcdir)/doc/libtool.1: $(srcdir)/$(auxdir)/ltmain.sh
93- $(update_mans) --help-option=--help-all libtool
94+ $(update_mans) --help-option=--help-all ${build_alias}-libtool
95 $(srcdir)/doc/libtoolize.1: $(srcdir)/libtoolize.in
96 $(update_mans) libtoolize
97
98@@ -523,12 +523,12 @@ TESTS_ENVIRONMENT = MAKE="$(MAKE)" CC="$
99
100 BUILDCHECK_ENVIRONMENT = _lt_pkgdatadir="$(abs_top_srcdir)" \
101 LIBTOOLIZE="$(abs_top_builddir)/libtoolize" \
102- LIBTOOL="$(abs_top_builddir)/libtool" \
103+ LIBTOOL="$(abs_top_builddir)/$(host_alias)-libtool" \
104 tst_aclocaldir="$(abs_top_srcdir)/libltdl/m4"
105
106 INSTALLCHECK_ENVIRONMENT = \
107 LIBTOOLIZE="$(bindir)/`echo libtoolize | sed '$(program_transform_name)'`" \
108- LIBTOOL="$(bindir)/`echo libtool | sed '$(program_transform_name)'`" \
109+ LIBTOOL="$(bindir)/`echo $(host_alias)-libtool | sed '$(program_transform_name)'`" \
110 LTDLINCL="-I$(includedir)" \
111 LIBLTDL="$(libdir)/libltdl.la" \
112 tst_aclocaldir="$(aclocaldir)"
113@@ -679,7 +679,7 @@ if HAVE_FC
114 TESTS += $(FC_TESTS)
115 endif
116
117-tests/demo-conf.test: libtool
118+tests/demo-conf.test: $(host_alias)-libtool
119
120 EXTRA_DIST += $(srcdir)/tests/defs.in tests/defs.m4sh \
121 $(COMMON_TESTS) $(CXX_TESTS) $(F77_TESTS) $(FC_TESTS)