summaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libtool/libtool-nativesdk_2.2.10.bb')
-rw-r--r--meta/packages/libtool/libtool-nativesdk_2.2.10.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool-nativesdk_2.2.10.bb b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
new file mode 100644
index 0000000000..05444c7cce
--- /dev/null
+++ b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
@@ -0,0 +1,26 @@
1require libtool_${PV}.bb
2
3PR = "r0"
4SRC_URI_append = " file://cross_compile.patch"
5
6inherit nativesdk
7
8do_configure_prepend () {
9 # Remove any existing libtool m4 since old stale versions would break
10 # any upgrade
11 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
12 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
13}
14
15do_install () {
16 autotools_do_install
17 install -d ${D}${bindir}/
18 install -m 0755 libtool ${D}${bindir}/
19}
20
21SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
22
23libtoolnativesdk_sysroot_preprocess () {
24 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
25 install -m 755 ${D}${bindir}/libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
26}