summaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool/libtool-cross_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libtool/libtool-cross_2.2.10.bb')
-rw-r--r--meta/packages/libtool/libtool-cross_2.2.10.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool-cross_2.2.10.bb b/meta/packages/libtool/libtool-cross_2.2.10.bb
new file mode 100644
index 0000000000..08b27f47be
--- /dev/null
+++ b/meta/packages/libtool/libtool-cross_2.2.10.bb
@@ -0,0 +1,41 @@
1require libtool_${PV}.bb
2
3PR = "r0"
4PACKAGES = ""
5SRC_URI_append = " file://cross_compile.patch "
6
7DEPENDS += "libtool-native"
8
9DOLT_PATCH = ""
10DOLT_PATCH_arm = " file://add_dolt.patch"
11DOLT_PATCH_i586 = " file://add_dolt.patch"
12
13#SRC_URI_append_linux = "${DOLT_PATCH}"
14#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
15
16do_configure_prepend () {
17 # Remove any existing libtool m4 since old stale versions would break
18 # any upgrade
19 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
20 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
21}
22
23do_install () {
24 install -d ${D}${bindir}/
25 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
26 install -d ${D}${datadir}/libtool/
27 install -d ${D}${datadir}/aclocal/
28 install -c ${S}/libltdl/config/config.guess ${D}${datadir}/libtool/
29 install -c ${S}/libltdl/config/config.sub ${D}${datadir}/libtool/
30 install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${D}${datadir}/libtool/
31 install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${D}${datadir}/aclocal/
32 install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${D}${datadir}/aclocal/
33 install -c -m 0644 ${WORKDIR}/dolt.m4 ${D}${datadir}/aclocal/
34}
35
36SYSROOT_PREPROCESS_FUNCS += "libtoolcross_sysroot_preprocess"
37
38libtoolcross_sysroot_preprocess () {
39 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
40 install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
41}