summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/glibc/glibc_2.6.1.bb')
-rw-r--r--meta/packages/glibc/glibc_2.6.1.bb150
1 files changed, 150 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc_2.6.1.bb b/meta/packages/glibc/glibc_2.6.1.bb
new file mode 100644
index 0000000000..4c59bbdc13
--- /dev/null
+++ b/meta/packages/glibc/glibc_2.6.1.bb
@@ -0,0 +1,150 @@
1require glibc.inc
2PR = "r3"
3
4ARM_INSTRUCTION_SET = "arm"
5
6PACKAGES_DYNAMIC = "libc6*"
7RPROVIDES_${PN}-dev = "libc6-dev"
8
9# the -isystem in bitbake.conf screws up glibc do_stage
10BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
11TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
12
13
14FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4"
15
16GLIBC_ADDONS ?= "ports,nptl,libidn"
17
18GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN"
19
20#
21# For now, we will skip building of a gcc package if it is a uclibc one
22# and our build is not a uclibc one, and we skip a glibc one if our build
23# is a uclibc build.
24#
25# See the note in gcc/gcc_3.4.0.oe
26#
27
28python __anonymous () {
29 import bb, re
30 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
31 if uc_os:
32 raise bb.parse.SkipPackage("incompatible with target %s" %
33 bb.data.getVar('TARGET_OS', d, 1))
34}
35
36RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
37
38SRC_URI = "\
39 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
40 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-${PV}.tar.bz2 \
41 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-${PV}.tar.bz2 \
42 file://arm-memcpy.patch;patch=1 \
43 file://arm-longlong.patch;patch=1 \
44 file://fhs-linux-paths.patch;patch=1 \
45 file://dl-cache-libcmp.patch;patch=1 \
46 file://ldsocache-varrun.patch;patch=1 \
47 file://nptl-crosscompile.patch;patch=1 \
48 file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1;pnum=0 \
49 file://glibc-check_pf.patch;patch=1;pnum=0 \
50 file://zecke-sane-readelf.patch;patch=1 \
51 file://ldd-unbash.patch;patch=1 \
52 file://generic-bits_select.h \
53 file://generic-bits_types.h \
54 file://generic-bits_typesizes.h \
55 file://generic-bits_time.h \
56 file://etc/ld.so.conf \
57 file://generate-supported.mk \
58 file://glibc-2.6.1-RTLD_SINGLE_THREAD_P-1.patch;patch=1 \
59"
60
61# Build fails on sh3 and sh4 without additional patches
62SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
63SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
64
65# PowerPC Patches to add support for soft-float
66SRC_URI_append_powerpc = "file://powerpc-sqrt-hack.diff;patch=1"
67
68S = "${WORKDIR}/glibc-${PV}"
69B = "${WORKDIR}/build-${TARGET_SYS}"
70
71EXTRA_OECONF = "\
72 --enable-kernel=${OLDEST_KERNEL} \
73 --without-cvs --disable-profile --disable-debug --without-gd \
74 --enable-clocale=gnu \
75 --enable-add-ons=${GLIBC_ADDONS} \
76 --with-headers=${STAGING_INCDIR} \
77 --without-selinux \
78 ${GLIBC_EXTRA_OECONF} \
79"
80
81EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
82
83do_munge() {
84 # Integrate ports and libidn into tree
85 mv ${WORKDIR}/glibc-ports-${PV} ${S}/ports
86 mv ${WORKDIR}/glibc-libidn-${PV} ${S}/libidn
87
88 # Ports isn't really working... Fix it
89 # Some of this is rather dirty, but it seems to be the only
90 # quick way to get this cruft to compile
91 rm -rf ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads
92 ln -s nptl ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads
93 cp ${S}/nptl/sysdeps/pthread/bits/sigthread.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
94 cp ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
95 cp ${S}/sysdeps/wordsize-32/bits/wordsize.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
96 cp ${WORKDIR}/generic-bits_select.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/select.h
97 cp ${WORKDIR}/generic-bits_types.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/types.h
98 cp ${WORKDIR}/generic-bits_typesizes.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/typesizes.h
99 cp ${WORKDIR}/generic-bits_time.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/time.h
100 # Copy in generic stuff for not yet implemented headers
101 for i in ${S}/bits/*.h; do
102 F=`basename $i`
103 [ "$F" = "local_lim.h" ] && continue
104 [ "$F" = "errno.h" ] && continue
105 test -e ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/$F || test -e ${S}/ports/sysdeps/arm/bits/$F || test -e ${S}/sysdeps/unix/sysv/linux/bits/$F || test -e ${S}/sysdeps/ieee754/bits/$F || cp $i ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
106 done
107 # This is harmful; we need to get the one from nptl/sysdeps/pthreads
108 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/libc-lock.h
109 # Obsoleted by sysdeps/arm/{fpu,eabi}/bits/fenv.h
110 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/fenv.h
111 # Obsoleted by sysdeps/gnu/bits/utmp.h
112 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/utmp.h
113}
114
115addtask munge before do_patch after do_unpack
116
117
118do_configure () {
119# override this function to avoid the autoconf/automake/aclocal/autoheader
120# calls for now
121# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
122# version check and doesn't really help with anything
123 if [ -z "`which rpcgen`" ]; then
124 echo "rpcgen not found. Install glibc-devel."
125 exit 1
126 fi
127 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
128 CPPFLAGS="" oe_runconf
129}
130
131rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
132 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
133 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
134
135do_compile () {
136 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
137 unset LDFLAGS
138 base_do_compile
139 (
140 cd ${S}/sunrpc/rpcsvc
141 for r in ${rpcsvc}; do
142 h=`echo $r|sed -e's,\.x$,.h,'`
143 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
144 done
145 )
146}
147
148require glibc-stage.inc
149
150require glibc-package.bbclass