summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-configure-runtime.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-initial_4.3.3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb2
-rw-r--r--meta/packages/gcc/gcc-package-cross.inc4
4 files changed, 5 insertions, 5 deletions
diff --git a/meta/packages/gcc/gcc-configure-runtime.inc b/meta/packages/gcc/gcc-configure-runtime.inc
index e20c72fa05..175e08ad14 100644
--- a/meta/packages/gcc/gcc-configure-runtime.inc
+++ b/meta/packages/gcc/gcc-configure-runtime.inc
@@ -11,7 +11,7 @@ RUNTIMETARGET = "libgcc libssp libstdc++-v3"
11# libgfortran 11# libgfortran
12 12
13do_configure () { 13do_configure () {
14 cp ${CROSS_DIR}/include/gcc-build-internal/* ${S}/gcc 14 cp ${STAGING_DIR_NATIVE}${prefix_native}/include/gcc-build-internal/* ${S}/gcc
15 for d in ${RUNTIMETARGET}; do 15 for d in ${RUNTIMETARGET}; do
16 echo "Configuring $d" 16 echo "Configuring $d"
17 mkdir -p ${B}/$d/ 17 mkdir -p ${B}/$d/
diff --git a/meta/packages/gcc/gcc-cross-initial_4.3.3.bb b/meta/packages/gcc/gcc-cross-initial_4.3.3.bb
index 8a429d54fe..2aae639fbc 100644
--- a/meta/packages/gcc/gcc-cross-initial_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross-initial_4.3.3.bb
@@ -5,6 +5,6 @@ PR = "r1"
5 5
6# Hack till we fix *libc properly 6# Hack till we fix *libc properly
7do_install_append() { 7do_install_append() {
8 ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/ 8 ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include/
9} 9}
10 10
diff --git a/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb b/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb
index 6de46f7e27..eda678ef2f 100644
--- a/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross-intermediate_4.3.3.bb
@@ -4,6 +4,6 @@ PR = "r1"
4 4
5# Hack till we fix *libc properly 5# Hack till we fix *libc properly
6do_install_append() { 6do_install_append() {
7 ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/ 7 ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${D}${STAGING_DIR_NATIVE}${prefix_native}/lib/gcc/${TARGET_SYS}/${BINV}/include/
8} 8}
9 9
diff --git a/meta/packages/gcc/gcc-package-cross.inc b/meta/packages/gcc/gcc-package-cross.inc
index 396631edd6..04ae78a88b 100644
--- a/meta/packages/gcc/gcc-package-cross.inc
+++ b/meta/packages/gcc/gcc-package-cross.inc
@@ -8,8 +8,8 @@ do_install () {
8 8
9 # Link gfortran to g77 to satisfy not-so-smart configure or hard coded g77 9 # Link gfortran to g77 to satisfy not-so-smart configure or hard coded g77
10 # gfortran is fully backwards compatible. This is a safe and practical solution. 10 # gfortran is fully backwards compatible. This is a safe and practical solution.
11 ln -sf ${CROSS_DIR}/bin/${TARGET_PREFIX}gfortran ${CROSS_DIR}/bin/${TARGET_PREFIX}g77 || true 11 ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/bin/${TARGET_PREFIX}gfortran ${STAGING_DIR_NATIVE}${prefix_native}/bin/${TARGET_PREFIX}g77 || true
12 ln -sf ${CROSS_DIR}/${TARGET_SYS}/bin/gfortran ${CROSS_DIR}/${TARGET_SYS}/bin/g77 || true 12 ln -sf ${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin/gfortran ${STAGING_DIR_NATIVE}/${prefix_native}/${TARGET_SYS}/bin/g77 || true
13 13
14 # Remove things we don't need but keep share/java 14 # Remove things we don't need but keep share/java
15 for d in info man share/doc share/locale share/man share/info; do 15 for d in info man share/doc share/locale share/man share/info; do