summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc_4.1.2.bb')
-rw-r--r--meta/packages/gcc/gcc_4.1.2.bb57
1 files changed, 5 insertions, 52 deletions
diff --git a/meta/packages/gcc/gcc_4.1.2.bb b/meta/packages/gcc/gcc_4.1.2.bb
index c4a124081f..c51eb23b05 100644
--- a/meta/packages/gcc/gcc_4.1.2.bb
+++ b/meta/packages/gcc/gcc_4.1.2.bb
@@ -1,54 +1,7 @@
1PR = "r3" 1PR = "r11"
2DESCRIPTION = "The GNU cc and gcc C compilers."
3HOMEPAGE = "http://www.gnu.org/software/gcc/"
4SECTION = "devel"
5LICENSE = "GPL"
6 2
7ARM_INSTRUCTION_SET = "arm" 3require gcc-${PV}.inc
8 4require gcc-configure-target.inc
9inherit autotools gettext 5require gcc-package-target.inc
10
11require gcc-package.inc
12
13SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
14 file://100-uclibc-conf.patch;patch=1 \
15 file://110-arm-eabi.patch;patch=1 \
16 file://200-uclibc-locale.patch;patch=1 \
17 file://300-libstdc++-pic.patch;patch=1 \
18 file://301-missing-execinfo_h.patch;patch=1 \
19 file://302-c99-snprintf.patch;patch=1 \
20 file://303-c99-complex-ugly-hack.patch;patch=1 \
21 file://304-index_macro.patch;patch=1 \
22 file://602-sdk-libstdc++-includes.patch;patch=1 \
23 file://740-sh-pr24836.patch;patch=1 \
24 file://800-arm-bigendian.patch;patch=1 \
25 file://arm-nolibfloat.patch;patch=1 \
26 file://arm-softfloat.patch;patch=1 \
27 file://gcc41-configure.in.patch;patch=1 \
28 file://arm-thumb.patch;patch=1 \
29 file://arm-thumb-cache.patch;patch=1 \
30 file://ldflags.patch;patch=1 \
31 file://zecke-xgcc-cpp.patch;patch=1 \
32 file://unbreak-armv4t.patch;patch=1 \
33 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
34 file://cache-amnesia.patch;patch=1 \
35 "
36
37SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
38
39#Set the fortran bits
40# 'fortran' or '', not 'f77' like gcc3 had
41FORTRAN = ""
42HAS_GFORTRAN = "no"
43HAS_G2C = "no"
44
45#Set the java bits
46JAVA_arm = ""
47JAVA = ""
48
49LANGUAGES = "c,c++${FORTRAN}${JAVA}"
50require gcc3-build.inc
51
52
53EXTRA_OECONF += " --disable-libssp "
54 6
7ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"