summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-cross-sdk_4.1.1.bb')
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.1.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb b/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb
new file mode 100644
index 0000000000..eaf7e7024a
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "The GNU cc and gcc C compilers."
2require gcc_${PV}.bb
3PR = "r0"
4
5inherit sdk
6
7FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
8
9DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
10PACKAGES = "${PN}"
11
12require gcc4-build-sdk.inc
13require gcc-package-sdk.inc
14
15SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
16 file://100-uclibc-conf.patch;patch=1 \
17 file://110-arm-eabi.patch;patch=1 \
18 file://200-uclibc-locale.patch;patch=1 \
19 file://300-libstdc++-pic.patch;patch=1 \
20 file://301-missing-execinfo_h.patch;patch=1 \
21 file://302-c99-snprintf.patch;patch=1 \
22 file://303-c99-complex-ugly-hack.patch;patch=1 \
23 file://304-index_macro.patch;patch=1 \
24 file://602-sdk-libstdc++-includes.patch;patch=1 \
25 file://740-sh-pr24836.patch;patch=1 \
26 file://800-arm-bigendian.patch;patch=1 \
27 file://arm-nolibfloat.patch;patch=1 \
28 file://arm-softfloat.patch;patch=1 \
29 file://gcc41-configure.in.patch;patch=1 \
30 file://arm-thumb.patch;patch=1 \
31 file://arm-thumb-cache.patch;patch=1 \
32 file://ldflags.patch;patch=1 \
33 file://cse.patch;patch=1 \
34 file://unbreak-armv4t.patch;patch=1 \
35 file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
36 file://gcc-4.1.1-pr13685-1.patch;patch=1 \
37 file://gcc-ignore-cache.patch;patch=1 \
38 "