summaryrefslogtreecommitdiffstats
path: root/meta/packages/flac/flac_1.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/flac/flac_1.1.2.bb')
-rw-r--r--meta/packages/flac/flac_1.1.2.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/packages/flac/flac_1.1.2.bb b/meta/packages/flac/flac_1.1.2.bb
new file mode 100644
index 0000000000..ec9d1b7197
--- /dev/null
+++ b/meta/packages/flac/flac_1.1.2.bb
@@ -0,0 +1,82 @@
1DESCRIPTION = "FLAC is a Free Lossless Audio Codec."
2MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
3LICENSE = "BSD GPL"
4SECTION = "libs"
5DEPENDS = "libogg"
6PR = "r4"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
9 file://disable-xmms-plugin.patch;patch=1 \
10 file://xmms.m4"
11
12S = "${WORKDIR}/flac-${PV}"
13
14inherit autotools
15
16EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
17 --with-ogg-libraries=${STAGING_LIBDIR} \
18 --with-ogg-includes=${STAGING_INCDIR} \
19 --without-xmms-prefix \
20 --without-xmms-exec-prefix \
21 --without-libiconv-prefix \
22 --without-id3lib"
23
24PACKAGES += "libflac libflac++ liboggflac liboggflac++"
25FILES_${PN} = "${bindir}"
26FILES_libflac = "${libdir}/libFLAC.so.*"
27FILES_libflac++ = "${libdir}/libFLAC++.so.*"
28FILES_liboggflac = "${libdir}/libOggFLAC.so.*"
29FILES_liboggflac++ = "${libdir}/libOggFLAC++.so.*"
30
31do_configure () {
32 install -d ${S}/m4
33 install -m 0644 ${WORKDIR}/xmms.m4 ${S}/m4/
34 autotools_do_configure
35}
36
37do_stage () {
38 install -d ${STAGING_DATADIR}/aclocal
39
40 oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/
41 install -d ${STAGING_INCDIR}/OggFLAC
42 install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h
43
44 install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h
45 install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h
46 install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h
47 install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/
48
49 oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/
50 install -d ${STAGING_INCDIR}/FLAC
51 install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h
52 install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h
53 install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h
54 install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h
55 install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h
56 install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h
57 install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h
58 install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h
59 install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h
60 install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h
61 install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h
62 install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h
63 install -m 0644 ${S}/include/FLAC/callback.h ${STAGING_INCDIR}/FLAC/callback.h
64 install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/
65
66 oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/
67 install -d ${STAGING_INCDIR}/FLAC++
68 install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h
69 install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h
70 install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h
71 install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h
72 install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h
73 install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/
74
75 oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/
76 install -d ${STAGING_INCDIR}/OggFLAC++
77 install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h
78 install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h
79 install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h
80 install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h
81 install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/
82}