summaryrefslogtreecommitdiffstats
path: root/meta/packages/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/elfutils/elfutils_0.148.bb')
-rw-r--r--meta/packages/elfutils/elfutils_0.148.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/packages/elfutils/elfutils_0.148.bb b/meta/packages/elfutils/elfutils_0.148.bb
new file mode 100644
index 0000000000..15aa504794
--- /dev/null
+++ b/meta/packages/elfutils/elfutils_0.148.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
2HOMEPAGE = "https://fedorahosted.org/elfutils"
3SECTION = "base"
4LICENSE = "GPLv2 with exceptions"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
6 file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
7DEPENDS = "libtool"
8
9PR = "r0"
10
11SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2"
12
13# pick the patch from debian
14# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.148-1.debian.tar.gz
15
16SRC_URI += "\
17 file://redhat-portability.diff \
18 file://redhat-robustify.diff \
19 file://hppa_backend.diff \
20 file://arm_backend.diff \
21 file://mips_backend.diff \
22 file://m68k_backend.diff \
23 file://do-autoreconf.diff \
24 file://testsuite-ignore-elflint.diff \
25 file://elf_additions.diff \
26"
27
28# The buildsystem wants to generate 2 .h files from source using a binary it just built,
29# which can not pass the cross compiling, so let's work around it by adding 2 .h files
30# along with the do_configure_prepend()
31
32SRC_URI += "\
33 file://i386_dis.h \
34 file://x86_64_dis.h \
35"
36
37inherit autotools
38
39do_configure_prepend() {
40 sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
41
42 cp ${WORKDIR}/*dis.h ${S}/libcpu
43}
44
45# Package binaries that overlap with binutils separately
46PACKAGES =+ "${PN}-binutils"
47FILES_${PN}-binutils = "\
48 ${bindir}/addr2line \
49 ${bindir}/ld \
50 ${bindir}/nm \
51 ${bindir}/readelf \
52 ${bindir}/size \
53 ${bindir}/strip"
54# Fix library issues
55FILES_${PN} =+ "${libdir}/*-${PV}.so"
56
57# The elfutils package contains symlinks that trip up insane
58INSANE_SKIP_elfutils = "1"