summaryrefslogtreecommitdiffstats
path: root/meta/packages/dbus/dbus_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/dbus/dbus_1.0.2.bb')
-rw-r--r--meta/packages/dbus/dbus_1.0.2.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus_1.0.2.bb b/meta/packages/dbus/dbus_1.0.2.bb
new file mode 100644
index 0000000000..0fafa28d12
--- /dev/null
+++ b/meta/packages/dbus/dbus_1.0.2.bb
@@ -0,0 +1,63 @@
1DEFAULT_PREFERENCE = "-1"
2
3SECTION = "base"
4HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
5DESCRIPTION = "message bus system for applications to talk to one another"
6LICENSE = "GPL"
7DEPENDS = "expat glib-2.0 virtual/libintl"
8
9PR = "r1"
10
11SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
12 file://tmpdir.patch;patch=1 \
13 file://dbus-1.init \
14 file://cross.patch;patch=1 \
15 file://fix-install-daemon.patch;patch=1"
16
17inherit autotools pkgconfig update-rc.d gettext
18
19INITSCRIPT_NAME = "dbus-1"
20INITSCRIPT_PARAMS = "defaults"
21
22CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
23
24FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
25FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
26
27pkg_postinst_dbus() {
28#!/bin/sh
29
30# can't do adduser stuff offline
31if [ "x$D" != "x" ]; then
32 exit 1
33fi
34
35MESSAGEUSER=messagebus
36MESSAGEHOME=/var/run/dbus
37
38mkdir -p $MESSAGEHOME || true
39chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
40chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
41}
42
43EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \
44 --disable-doxygen-docs --with-xml=expat --without-x"
45
46do_stage () {
47 oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
48
49 autotools_stage_includes
50
51 mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
52 install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
53}
54
55do_install_append () {
56 install -d ${D}${sysconfdir}/init.d
57 install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
58}
59
60python populate_packages_prepend () {
61 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
62 bb.data.setVar('PKG_dbus', 'dbus-1', d)
63}