summaryrefslogtreecommitdiffstats
path: root/meta/packages/coreutils/coreutils-5.3.0
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/coreutils/coreutils-5.3.0')
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/futimens.patch44
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/install-cross.patch27
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/man.patch42
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch33
-rw-r--r--meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch11
5 files changed, 0 insertions, 157 deletions
diff --git a/meta/packages/coreutils/coreutils-5.3.0/futimens.patch b/meta/packages/coreutils/coreutils-5.3.0/futimens.patch
deleted file mode 100644
index 3cb2b6ab32..0000000000
--- a/meta/packages/coreutils/coreutils-5.3.0/futimens.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1Index: coreutils-5.3.0/lib/utimens.c
2===================================================================
3--- coreutils-5.3.0.orig/lib/utimens.c 2005-01-03 22:19:15.000000000 +0000
4+++ coreutils-5.3.0/lib/utimens.c 2007-07-01 19:12:32.000000000 +0000
5@@ -55,8 +55,8 @@
6 If TIMESPEC is null, set the time stamps to the current time. */
7
8 int
9-futimens (int fd ATTRIBUTE_UNUSED,
10- char const *file, struct timespec const timespec[2])
11+gl_futimens (int fd ATTRIBUTE_UNUSED,
12+ char const *file, struct timespec const timespec[2])
13 {
14 /* There's currently no interface to set file timestamps with
15 nanosecond resolution, so do the best we can, discarding any
16@@ -117,5 +117,5 @@
17 int
18 utimens (char const *file, struct timespec const timespec[2])
19 {
20- return futimens (-1, file, timespec);
21+ return gl_futimens (-1, file, timespec);
22 }
23Index: coreutils-5.3.0/lib/utimens.h
24===================================================================
25--- coreutils-5.3.0.orig/lib/utimens.h 2004-11-23 20:54:33.000000000 +0000
26+++ coreutils-5.3.0/lib/utimens.h 2007-07-01 19:12:37.000000000 +0000
27@@ -1,3 +1,3 @@
28 #include "timespec.h"
29-int futimens (int, char const *, struct timespec const [2]);
30+int gl_futimens (int, char const *, struct timespec const [2]);
31 int utimens (char const *, struct timespec const [2]);
32Index: coreutils-5.3.0/src/touch.c
33===================================================================
34--- coreutils-5.3.0.orig/src/touch.c 2004-11-23 20:54:35.000000000 +0000
35+++ coreutils-5.3.0/src/touch.c 2007-07-01 19:11:52.000000000 +0000
36@@ -191,7 +191,7 @@
37 t = timespec;
38 }
39
40- ok = (futimens (fd, file, t) == 0);
41+ ok = (gl_futimens (fd, file, t) == 0);
42 if (fd != -1)
43 ok &= (close (fd) == 0);
44
diff --git a/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch b/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch
deleted file mode 100644
index 98ba3d916c..0000000000
--- a/meta/packages/coreutils/coreutils-5.3.0/install-cross.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1--- src/install.c~ 2003-08-09 18:46:45.000000000 +0100
2+++ src/install.c 2004-03-27 18:38:45.000000000 +0000
3@@ -516,7 +516,14 @@
4 strip (const char *path)
5 {
6 int status;
7- pid_t pid = fork ();
8+ pid_t pid;
9+ char *strip_name;
10+
11+ strip_name = getenv ("STRIP");
12+ if (strip_name == NULL)
13+ strip_name = "strip";
14+
15+ pid = fork ();
16
17 switch (pid)
18 {
19@@ -524,7 +531,7 @@
20 error (EXIT_FAILURE, errno, _("fork system call failed"));
21 break;
22 case 0: /* Child. */
23- execlp ("strip", "strip", path, NULL);
24+ execlp (strip_name, "strip", path, NULL);
25 error (EXIT_FAILURE, errno, _("cannot run strip"));
26 break;
27 default: /* Parent. */
diff --git a/meta/packages/coreutils/coreutils-5.3.0/man.patch b/meta/packages/coreutils/coreutils-5.3.0/man.patch
deleted file mode 100644
index 5060e4fdff..0000000000
--- a/meta/packages/coreutils/coreutils-5.3.0/man.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- coreutils-5.3.0/configure.ac~man
7+++ coreutils-5.3.0/configure.ac
8@@ -237,6 +237,20 @@
9 AM_GNU_GETTEXT([external], [need-ngettext])
10 AM_GNU_GETTEXT_VERSION(0.13.1)
11
12+AC_MSG_CHECKING([whether to build man pages])
13+AC_ARG_WITH(manpages,
14+ AS_HELP_STRING([--with-manpages],
15+ [Enable building of manpages (default=yes)]),
16+ [cu_cv_build_manpages=$enableval],
17+ [cu_cv_build_manpages=yes])
18+# help2man doesn't work when crosscompiling, as it needs to run the
19+# binary that was built.
20+if test x"$cross_compiling" = x"yes"; then
21+ cu_cv_build_manpages=no
22+fi
23+AC_MSG_RESULT($cu_cv_build_manpages)
24+AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
25+
26 AC_CONFIG_FILES(
27 Makefile
28 doc/Makefile
29--- coreutils-5.3.0/Makefile.am~man
30+++ coreutils-5.3.0/Makefile.am
31@@ -1,6 +1,11 @@
32 ## Process this file with automake to produce Makefile.in -*-Makefile-*-
33
34+if ENABLE_MANPAGES
35 SUBDIRS = lib src doc man po tests
36+else
37+SUBDIRS = lib src doc po tests
38+endif
39+
40 EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
41 .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
42 .x-sc_space_tab .x-sc_sun_os_names \
diff --git a/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch b/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
deleted file mode 100644
index 148a5f4f8f..0000000000
--- a/meta/packages/coreutils/coreutils-5.3.0/rename-tee-for-glibc2.5.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1Glibc 2.5 has a function called tee which conflicts with the same function
2in coreutils. This patch renames the function to tee_files (as is done in
3the newer coreutils versions.)
4
5--- coreutils-5.3.0/src/tee.c 2006/10/23 07:35:00 1.1
6+++ coreutils-5.3.0/src/tee.c 2006/10/23 07:35:16
7@@ -31,7 +31,7 @@
8
9 #define AUTHORS "Mike Parker", "Richard M. Stallman", "David MacKenzie"
10
11-static bool tee (int nfiles, const char **files);
12+static bool tee_files (int nfiles, const char **files);
13
14 /* If true, append to output files rather than truncating them. */
15 static bool append;
16@@ -121,7 +121,7 @@
17 /* Do *not* warn if tee is given no file arguments.
18 POSIX requires that it work when given no arguments. */
19
20- ok = tee (argc - optind, (const char **) &argv[optind]);
21+ ok = tee_files (argc - optind, (const char **) &argv[optind]);
22 if (close (STDIN_FILENO) != 0)
23 error (EXIT_FAILURE, errno, _("standard input"));
24
25@@ -133,7 +133,7 @@
26 Return true if successful. */
27
28 static bool
29-tee (int nfiles, const char **files)
30+tee_files (int nfiles, const char **files)
31 {
32 FILE **descriptors;
33 char buffer[BUFSIZ];
diff --git a/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch b/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch
deleted file mode 100644
index 5eb3fca676..0000000000
--- a/meta/packages/coreutils/coreutils-5.3.0/uptime-pow-lib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- coreutils-5.3.0/src/Makefile.am.orig 2005-09-27 22:34:35.659272058 -0700
2+++ coreutils-5.3.0/src/Makefile.am 2005-09-27 22:34:39.403507668 -0700
3@@ -74,7 +74,7 @@
4 sleep_LDADD = $(nanosec_libs)
5 tail_LDADD = $(nanosec_libs)
6
7-uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
8+uptime_LDADD = $(LDADD) $(POW_LIB) $(GETLOADAVG_LIBS)
9
10 su_LDADD = $(LDADD) $(LIB_CRYPT)
11