summaryrefslogtreecommitdiffstats
path: root/meta/packages/busybox/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/busybox/files')
-rw-r--r--meta/packages/busybox/files/busybox-appletlib-dependency.patch15
-rw-r--r--meta/packages/busybox/files/find-touchscreen.sh9
-rwxr-xr-xmeta/packages/busybox/files/mdev11
-rw-r--r--meta/packages/busybox/files/mdev.conf33
-rw-r--r--meta/packages/busybox/files/mountall1
-rw-r--r--meta/packages/busybox/files/simple.script72
6 files changed, 141 insertions, 0 deletions
diff --git a/meta/packages/busybox/files/busybox-appletlib-dependency.patch b/meta/packages/busybox/files/busybox-appletlib-dependency.patch
new file mode 100644
index 0000000000..3efd4c0882
--- /dev/null
+++ b/meta/packages/busybox/files/busybox-appletlib-dependency.patch
@@ -0,0 +1,15 @@
1Index: busybox-1.13.2/Makefile
2===================================================================
3--- busybox-1.13.2.orig/Makefile 2009-03-19 15:44:37.419270265 +0300
4+++ busybox-1.13.2/Makefile 2009-03-19 15:45:57.737521296 +0300
5@@ -471,6 +471,10 @@
6 util-linux/ \
7 util-linux/volume_id/ \
8
9+# Lib interdeps
10+# libbb uses headers generated in applets
11+libbb: applets
12+
13 endif # KBUILD_EXTMOD
14
15 ifeq ($(dot-config),1)
diff --git a/meta/packages/busybox/files/find-touchscreen.sh b/meta/packages/busybox/files/find-touchscreen.sh
new file mode 100644
index 0000000000..1582ea891c
--- /dev/null
+++ b/meta/packages/busybox/files/find-touchscreen.sh
@@ -0,0 +1,9 @@
1#!/bin/sh
2
3if [ `egrep "input:.*-e0.*,3,.*a0,1,.*18,.*" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
4 ln -sf /dev/input/$MDEV /dev/input/touchscreen0
5fi
6
7if [ `egrep "ads7846" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
8 ln -sf /dev/input/$MDEV /dev/input/touchscreen0
9fi
diff --git a/meta/packages/busybox/files/mdev b/meta/packages/busybox/files/mdev
new file mode 100755
index 0000000000..4eed51e94c
--- /dev/null
+++ b/meta/packages/busybox/files/mdev
@@ -0,0 +1,11 @@
1#!/bin/sh
2
3mount -t tmpfs tmpfs /dev -o size=64k,mode=0755
4
5mkdir /dev/pts /dev/shm
6
7mount -t devpts devpts /dev/pts
8
9echo "/sbin/mdev" >/proc/sys/kernel/hotplug
10
11mdev -s
diff --git a/meta/packages/busybox/files/mdev.conf b/meta/packages/busybox/files/mdev.conf
new file mode 100644
index 0000000000..163ebfe45d
--- /dev/null
+++ b/meta/packages/busybox/files/mdev.conf
@@ -0,0 +1,33 @@
1console 0:0 0600
2cpu_dma_latency 0:0 0660
3fb0:0 44 0660
4full 0:0 0666
5initctl 0:0 0600
6ircomm[0-9].* 0:20 0660
7kmem 0:15 0640
8kmsg 0:0 0660
9log 0:0 0666
10loop[0-9].* 0:6 0640
11mem 0:15 0640
12network_latency 0:0 0660
13network_throughput 0:0 0660
14null 0:0 0666
15port 0:15 0640
16ptmx 0:5 0666
17ram[0-9].* 0:6 0640
18random 0:0 0666
19sda 0:6 0640
20tty 0:5 0666
21tty.* 0:0 0620
22urandom 0:0 0666
23usbdev.* 0:0 0660
24vcs.* 0:5 0660
25zero 0:0 0666
26
27pcm.* 0:0 0660 =snd/
28control.* 0:0 0660 =snd/
29timer 0:0 0660 =snd/
30
31event.* 0:0 0660 =input/ @/etc/mdev/find-touchscreen.sh
32mice 0:0 0660 =input/
33mouse.* 0:0 0660 =input/
diff --git a/meta/packages/busybox/files/mountall b/meta/packages/busybox/files/mountall
new file mode 100644
index 0000000000..d5408b8f8d
--- /dev/null
+++ b/meta/packages/busybox/files/mountall
@@ -0,0 +1 @@
MOUNTALL="-t nonfs,nosmbfs,noncpfs"
diff --git a/meta/packages/busybox/files/simple.script b/meta/packages/busybox/files/simple.script
new file mode 100644
index 0000000000..5cc21b9de2
--- /dev/null
+++ b/meta/packages/busybox/files/simple.script
@@ -0,0 +1,72 @@
1#!/bin/sh
2
3# udhcpc script edited by Tim Riker <Tim@Rikers.org>
4
5[ -z "$1" ] && echo "Error: should be called from udhcpc" && exit 1
6
7RESOLV_CONF="/etc/resolv.conf"
8[ -n "$broadcast" ] && BROADCAST="broadcast $broadcast"
9[ -n "$subnet" ] && NETMASK="netmask $subnet"
10
11# return 0 if root is mounted on a network filesystem
12root_is_nfs() {
13 grep -qe '^/dev/root.*\(nfs\|smbfs\|ncp\|coda\) .*' /proc/mounts
14}
15
16have_bin_ip=0
17if [ -x /bin/ip ]; then
18 have_bin_ip=1
19fi
20
21case "$1" in
22 deconfig)
23 if ! root_is_nfs ; then
24 if [ $have_bin_ip -eq 1 ]; then
25 ip addr flush dev $interface
26 ip link set dev $interface up
27 else
28 /sbin/ifconfig $interface 0.0.0.0
29 fi
30 fi
31 ;;
32
33 renew|bound)
34 if [ $have_bin_ip -eq 1 ]; then
35 ip addr add dev $interface local $ip/$mask $BROADCAST
36 else
37 /sbin/ifconfig $interface $ip $BROADCAST $NETMASK
38 fi
39
40 if [ -n "$router" ] ; then
41 if ! root_is_nfs ; then
42 if [ $have_bin_ip -eq 1 ]; then
43 while ip route del default 2>/dev/null ; do
44 :
45 done
46 else
47 while route del default gw 0.0.0.0 dev $interface 2>/dev/null ; do
48 :
49 done
50 fi
51 fi
52
53 metric=0
54 for i in $router ; do
55 if [ $have_bin_ip -eq 1 ]; then
56 ip route add default via $i metric $((metric++))
57 else
58 route add default gw $i dev $interface metric $((metric++)) 2>/dev/null
59 fi
60 done
61 fi
62
63 echo -n > $RESOLV_CONF
64 [ -n "$domain" ] && echo search $domain >> $RESOLV_CONF
65 for i in $dns ; do
66 echo adding dns $i
67 echo nameserver $i >> $RESOLV_CONF
68 done
69 ;;
70esac
71
72exit 0