summaryrefslogtreecommitdiffstats
path: root/meta/packages/busybox/busybox_1.15.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/busybox/busybox_1.15.3.bb')
-rw-r--r--meta/packages/busybox/busybox_1.15.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/packages/busybox/busybox_1.15.3.bb b/meta/packages/busybox/busybox_1.15.3.bb
new file mode 100644
index 0000000000..25c2983e1e
--- /dev/null
+++ b/meta/packages/busybox/busybox_1.15.3.bb
@@ -0,0 +1,37 @@
1require busybox.inc
2PR = "1"
3
4SRC_URI = "\
5 http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
6 file://udhcpscript.patch;patch=1 \
7 file://udhcpc-fix-nfsroot.patch;patch=1 \
8 file://B921600.patch;patch=1 \
9 file://get_header_tar.patch;patch=1 \
10 file://busybox-appletlib-dependency.patch;patch=1 \
11 file://0000-wget-no-check-certificate.patch;patch=1 \
12 file://run-parts.in.usr-bin.patch;patch=1 \
13 file://find-touchscreen.sh \
14 file://busybox-cron \
15 file://busybox-httpd \
16 file://busybox-udhcpd \
17 file://default.script file://simple.script \
18 file://hwclock.sh \
19 file://mount.busybox \
20 file://mountall \
21 file://syslog \
22 file://syslog.conf \
23 file://umount.busybox \
24 file://defconfig \
25 file://mdev \
26 file://mdev.conf \
27"
28
29EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
30
31do_install_append() {
32 install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
33 install -d ${D}${sysconfdir}/init.d/
34 install -d ${D}${sysconfdir}/mdev
35 install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
36 install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
37}