summaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/files/maturin/guessing-game/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'meta/lib/oeqa/files/maturin/guessing-game/Cargo.toml')
-rw-r--r--meta/lib/oeqa/files/maturin/guessing-game/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/lib/oeqa/files/maturin/guessing-game/Cargo.toml b/meta/lib/oeqa/files/maturin/guessing-game/Cargo.toml
new file mode 100644
index 0000000000..de95025e86
--- /dev/null
+++ b/meta/lib/oeqa/files/maturin/guessing-game/Cargo.toml
@@ -0,0 +1,20 @@
1[package]
2name = "guessing-game"
3version = "0.1.0"
4edition = "2021"
5
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
7
8[lib]
9name = "guessing_game"
10# "cdylib" is necessary to produce a shared library for Python to import from.
11crate-type = ["cdylib"]
12
13[dependencies]
14rand = "0.8.4"
15
16[dependencies.pyo3]
17version = "0.19.0"
18# "abi3-py38" tells pyo3 (and maturin) to build using the stable ABI with minimum Python version 3.8
19features = ["abi3-py38"]
20