summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools3.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/setuptools3.bbclass')
-rw-r--r--meta/classes/setuptools3.bbclass38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
deleted file mode 100644
index 4c6e79ee9a..0000000000
--- a/meta/classes/setuptools3.bbclass
+++ /dev/null
@@ -1,38 +0,0 @@
1#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7inherit setuptools3-base python_pep517
8
9DEPENDS += "python3-setuptools-native python3-wheel-native"
10
11SETUPTOOLS_BUILD_ARGS ?= ""
12
13SETUPTOOLS_SETUP_PATH ?= "${S}"
14
15setuptools3_do_configure() {
16 :
17}
18
19setuptools3_do_compile() {
20 cd ${SETUPTOOLS_SETUP_PATH}
21 NO_FETCH_BUILD=1 \
22 STAGING_INCDIR=${STAGING_INCDIR} \
23 STAGING_LIBDIR=${STAGING_LIBDIR} \
24 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
25 bdist_wheel --verbose --dist-dir ${PEP517_WHEEL_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
26 bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed."
27}
28setuptools3_do_compile[vardepsexclude] = "MACHINE"
29do_compile[cleandirs] += "${PEP517_WHEEL_PATH}"
30
31# This could be removed in the future but some recipes in meta-oe still use it
32setuptools3_do_install() {
33 python_pep517_do_install
34}
35
36EXPORT_FUNCTIONS do_configure do_compile do_install
37
38export LDSHARED="${CCLD} -shared"