summaryrefslogtreecommitdiffstats
path: root/meta/classes/gtk-doc.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/gtk-doc.bbclass')
-rw-r--r--meta/classes/gtk-doc.bbclass83
1 files changed, 0 insertions, 83 deletions
diff --git a/meta/classes/gtk-doc.bbclass b/meta/classes/gtk-doc.bbclass
deleted file mode 100644
index ef99e63faf..0000000000
--- a/meta/classes/gtk-doc.bbclass
+++ /dev/null
@@ -1,83 +0,0 @@
1# Helper class to pull in the right gtk-doc dependencies and configure
2# gtk-doc to enable or disable documentation building (which requries the
3# use of usermode qemu).
4
5# This variable is set to True if api-documentation is in
6# DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise.
7#
8# It should be used in recipes to determine whether gtk-doc based documentation should be built,
9# so that qemu use can be avoided when necessary.
10GTKDOC_ENABLED_class-native = "False"
11GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \
12 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}"
13
14# meson: default option name to enable/disable gtk-doc. This matches most
15# project's configuration. In doubts - check meson_options.txt in project's
16# source path.
17GTKDOC_MESON_OPTION ?= 'docs'
18GTKDOC_MESON_ENABLE_FLAG ?= 'true'
19GTKDOC_MESON_DISABLE_FLAG ?= 'false'
20
21# Auto enable/disable based on GTKDOC_ENABLED
22EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \
23 '--disable-gtk-doc', d)} "
24EXTRA_OEMESON_prepend_class-target = "-D${GTKDOC_MESON_OPTION}=${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_MESON_ENABLE_FLAG}', '${GTKDOC_MESON_DISABLE_FLAG}', d)} "
25
26# When building native recipes, disable gtkdoc, as it is not necessary,
27# pulls in additional dependencies, and makes build times longer
28EXTRA_OECONF_prepend_class-native = "--disable-gtk-doc "
29EXTRA_OECONF_prepend_class-nativesdk = "--disable-gtk-doc "
30EXTRA_OEMESON_prepend_class-native = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} "
31EXTRA_OEMESON_prepend_class-nativesdk = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} "
32
33# Even though gtkdoc is disabled on -native, gtk-doc package is still
34# needed for m4 macros.
35DEPENDS_append = " gtk-doc-native"
36
37# The documentation directory, where the infrastructure will be copied.
38# gtkdocize has a default of "." so to handle out-of-tree builds set this to $S.
39GTKDOC_DOCDIR ?= "${S}"
40
41export STAGING_DIR_HOST
42
43inherit python3native pkgconfig qemu
44DEPENDS_append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
45
46do_configure_prepend () {
47 # Need to use ||true as this is only needed if configure.ac both exists
48 # and uses GTK_DOC_CHECK.
49 gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true
50}
51
52do_compile_prepend_class-target () {
53 if [ ${GTKDOC_ENABLED} = True ]; then
54 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it
55 # can run target helper binaries through that.
56 qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
57 cat > ${B}/gtkdoc-qemuwrapper << EOF
58#!/bin/sh
59# Use a modules directory which doesn't exist so we don't load random things
60# which may then get deleted (or their dependencies) and potentially segfault
61export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy
62
63GIR_EXTRA_LIBS_PATH=\`find ${B} -name *.so -printf "%h\n"|sort|uniq| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH
64GIR_EXTRA_LIBS_PATH=\`find ${B} -name .libs| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH
65
66# meson sets this wrongly (only to libs in build-dir), qemu-wrapper_cmdline() and GIR_EXTRA_LIBS_PATH take care of it properly
67unset LD_LIBRARY_PATH
68
69if [ -d ".libs" ]; then
70 $qemu_binary ".libs/\$@"
71else
72 $qemu_binary "\$@"
73fi
74
75if [ \$? -ne 0 ]; then
76 echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help."
77 echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )"
78 exit 1
79fi
80EOF
81 chmod +x ${B}/gtkdoc-qemuwrapper
82 fi
83}