summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/cargo_common.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes-recipe/cargo_common.bbclass')
-rw-r--r--meta/classes-recipe/cargo_common.bbclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/classes-recipe/cargo_common.bbclass b/meta/classes-recipe/cargo_common.bbclass
index 509aa195c5..48cdd69bca 100644
--- a/meta/classes-recipe/cargo_common.bbclass
+++ b/meta/classes-recipe/cargo_common.bbclass
@@ -28,10 +28,10 @@ export PKG_CONFIG_ALLOW_CROSS = "1"
28# Don't instruct cargo to use crates downloaded by bitbake. Some rust packages, 28# Don't instruct cargo to use crates downloaded by bitbake. Some rust packages,
29# for example the rust compiler itself, come with their own vendored sources. 29# for example the rust compiler itself, come with their own vendored sources.
30# Specifying two [source.crates-io] will not work. 30# Specifying two [source.crates-io] will not work.
31CARGO_DISABLE_BITBAKE_VENDORING ?= "0" 31CARGO_DISABLE_BITBAKE_VENDORING ??= "0"
32 32
33# Used by libstd-rs to point to the vendor dir included in rustc src 33# Used by libstd-rs to point to the vendor dir included in rustc src
34CARGO_VENDORING_DIRECTORY ?= "${CARGO_HOME}/bitbake" 34CARGO_VENDORING_DIRECTORY ??= "${CARGO_HOME}/bitbake"
35 35
36# The directory of the Cargo.toml relative to the root directory, per default 36# The directory of the Cargo.toml relative to the root directory, per default
37# assume there's a Cargo.toml directly in the root directory 37# assume there's a Cargo.toml directly in the root directory
@@ -40,7 +40,7 @@ CARGO_SRC_DIR ??= ""
40# The actual path to the Cargo.toml 40# The actual path to the Cargo.toml
41CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml" 41CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"
42 42
43CARGO_RUST_TARGET_CCLD ?= "${RUST_TARGET_CCLD}" 43CARGO_RUST_TARGET_CCLD ??= "${RUST_TARGET_CCLD}"
44cargo_common_do_configure () { 44cargo_common_do_configure () {
45 mkdir -p ${CARGO_HOME}/bitbake 45 mkdir -p ${CARGO_HOME}/bitbake
46 46