summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/cargo_common.bbclass
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-12-08 12:00:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-09 19:17:11 +0000
commitdddfe1e3f4135d974c6692071e08f6e0a96df1b3 (patch)
tree430850e551952c1b7d9f6060e69fb151f4b17fce /meta/classes-recipe/cargo_common.bbclass
parent43df94f7af8422ebd1f2884992349ff1baae232b (diff)
downloadpoky-dddfe1e3f4135d974c6692071e08f6e0a96df1b3.tar.gz
rust: cargo: Convert single-valued variables to weak defaults
All of these variables are single-valued, so we can use weak-defaults for them and only see the final assignment after parsing. (From OE-Core rev: 3221e82a35a149fdf38fe66dcd5de758ac1b9185) Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/cargo_common.bbclass')
-rw-r--r--meta/classes-recipe/cargo_common.bbclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/classes-recipe/cargo_common.bbclass b/meta/classes-recipe/cargo_common.bbclass
index 509aa195c5..48cdd69bca 100644
--- a/meta/classes-recipe/cargo_common.bbclass
+++ b/meta/classes-recipe/cargo_common.bbclass
@@ -28,10 +28,10 @@ export PKG_CONFIG_ALLOW_CROSS = "1"
28# Don't instruct cargo to use crates downloaded by bitbake. Some rust packages, 28# Don't instruct cargo to use crates downloaded by bitbake. Some rust packages,
29# for example the rust compiler itself, come with their own vendored sources. 29# for example the rust compiler itself, come with their own vendored sources.
30# Specifying two [source.crates-io] will not work. 30# Specifying two [source.crates-io] will not work.
31CARGO_DISABLE_BITBAKE_VENDORING ?= "0" 31CARGO_DISABLE_BITBAKE_VENDORING ??= "0"
32 32
33# Used by libstd-rs to point to the vendor dir included in rustc src 33# Used by libstd-rs to point to the vendor dir included in rustc src
34CARGO_VENDORING_DIRECTORY ?= "${CARGO_HOME}/bitbake" 34CARGO_VENDORING_DIRECTORY ??= "${CARGO_HOME}/bitbake"
35 35
36# The directory of the Cargo.toml relative to the root directory, per default 36# The directory of the Cargo.toml relative to the root directory, per default
37# assume there's a Cargo.toml directly in the root directory 37# assume there's a Cargo.toml directly in the root directory
@@ -40,7 +40,7 @@ CARGO_SRC_DIR ??= ""
40# The actual path to the Cargo.toml 40# The actual path to the Cargo.toml
41CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml" 41CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"
42 42
43CARGO_RUST_TARGET_CCLD ?= "${RUST_TARGET_CCLD}" 43CARGO_RUST_TARGET_CCLD ??= "${RUST_TARGET_CCLD}"
44cargo_common_do_configure () { 44cargo_common_do_configure () {
45 mkdir -p ${CARGO_HOME}/bitbake 45 mkdir -p ${CARGO_HOME}/bitbake
46 46