summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel/linux')
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend22
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend23
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend23
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend21
4 files changed, 32 insertions, 57 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
index 6e5a129dd4..5b1b736b1c 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,13 +1,13 @@
1KBRANCH_genericx86 = "standard/base" 1KBRANCH:genericx86 = "standard/base"
2KBRANCH_genericx86-64 = "standard/base" 2KBRANCH:genericx86-64 = "standard/base"
3KBRANCH_edgerouter = "standard/edgerouter" 3KBRANCH:beaglebone-yocto = "standard/beaglebone"
4KBRANCH_beaglebone-yocto = "standard/beaglebone"
5 4
6KMACHINE_genericx86 ?= "common-pc" 5KMACHINE:genericarm64 ?= "genericarm64"
7KMACHINE_genericx86-64 ?= "common-pc-64" 6KMACHINE:genericx86 ?= "common-pc"
8KMACHINE_beaglebone-yocto ?= "beaglebone" 7KMACHINE:genericx86-64 ?= "common-pc-64"
8KMACHINE:beaglebone-yocto ?= "beaglebone"
9 9
10COMPATIBLE_MACHINE_genericx86 = "genericx86" 10COMPATIBLE_MACHINE:genericarm64 = "genericarm64"
11COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 11COMPATIBLE_MACHINE:genericx86 = "genericx86"
12COMPATIBLE_MACHINE_edgerouter = "edgerouter" 12COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
13COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 13COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend
deleted file mode 100644
index 87e47352a6..0000000000
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1KBRANCH_genericx86 = "v5.10/standard/base"
2KBRANCH_genericx86-64 = "v5.10/standard/base"
3KBRANCH_edgerouter = "v5.10/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.10/standard/beaglebone"
5
6KMACHINE_genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64"
8KMACHINE_beaglebone-yocto ?= "beaglebone"
9
10SRCREV_machine_genericx86 ?= "cdca78778415b4b3bd64e8390ee8adf04bf7e17a"
11SRCREV_machine_genericx86-64 ?= "cdca78778415b4b3bd64e8390ee8adf04bf7e17a"
12SRCREV_machine_edgerouter ?= "2e1fb8f84f09ca768eb531f33a126a40bb90e791"
13SRCREV_machine_beaglebone-yocto ?= "cdca78778415b4b3bd64e8390ee8adf04bf7e17a"
14
15COMPATIBLE_MACHINE_genericx86 = "genericx86"
16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
17COMPATIBLE_MACHINE_edgerouter = "edgerouter"
18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
19
20LINUX_VERSION_genericx86 = "5.10.12"
21LINUX_VERSION_genericx86-64 = "5.10.12"
22LINUX_VERSION_edgerouter = "5.10.12"
23LINUX_VERSION_beaglebone-yocto = "5.10.12"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend
deleted file mode 100644
index 35147d2da8..0000000000
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1KBRANCH_genericx86 = "v5.4/standard/base"
2KBRANCH_genericx86-64 = "v5.4/standard/base"
3KBRANCH_edgerouter = "v5.4/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.4/standard/beaglebone"
5
6KMACHINE_genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64"
8KMACHINE_beaglebone-yocto ?= "beaglebone"
9
10SRCREV_machine_genericx86 ?= "31db2b47ac7d8508080fbb7344399b501216de66"
11SRCREV_machine_genericx86-64 ?= "31db2b47ac7d8508080fbb7344399b501216de66"
12SRCREV_machine_edgerouter ?= "706efec4c1e270ec5dda92275898cd465dfdc7dd"
13SRCREV_machine_beaglebone-yocto ?= "706efec4c1e270ec5dda92275898cd465dfdc7dd"
14
15COMPATIBLE_MACHINE_genericx86 = "genericx86"
16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
17COMPATIBLE_MACHINE_edgerouter = "edgerouter"
18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
19
20LINUX_VERSION_genericx86 = "5.4.94"
21LINUX_VERSION_genericx86-64 = "5.4.94"
22LINUX_VERSION_edgerouter = "5.4.58"
23LINUX_VERSION_beaglebone-yocto = "5.4.58"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend
new file mode 100644
index 0000000000..3f33ec991d
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend
@@ -0,0 +1,21 @@
1COMPATIBLE_MACHINE:genericarm64 = "genericarm64"
2COMPATIBLE_MACHINE:genericx86 = "genericx86"
3COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
4COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"
5
6KBRANCH:genericx86 = "v6.6/standard/base"
7KBRANCH:genericx86-64 = "v6.6/standard/base"
8KBRANCH:beaglebone-yocto = "v6.6/standard/beaglebone"
9
10KMACHINE:genericarm64 ?= "genericarm64"
11KMACHINE:genericx86 ?= "common-pc"
12KMACHINE:genericx86-64 ?= "common-pc-64"
13KMACHINE:beaglebone-yocto ?= "beaglebone"
14
15SRCREV_machine:genericx86 ?= "06644f0d7193d7ec39d7fe41939a21953e7a0c65"
16SRCREV_machine:genericx86-64 ?= "06644f0d7193d7ec39d7fe41939a21953e7a0c65"
17SRCREV_machine:beaglebone-yocto ?= "06644f0d7193d7ec39d7fe41939a21953e7a0c65"
18
19LINUX_VERSION:genericx86 = "6.6.21"
20LINUX_VERSION:genericx86-64 = "6.6.21"
21LINUX_VERSION:beaglebone-yocto = "6.6.21"