summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
index 37193f5a33..d11e2e530e 100644
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "These are introductory examples to showcase the use of QEMU to ru
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
6 6
7SRCREV = "0bf9ea216e6f76be50726a3a74e527b7bbb0ad93" 7SRCREV = "31b4e5a337018b4a00a7426b0e5ed83b81df30c7"
8PV = "0.1+git${SRCPV}" 8PV = "0.1+git${SRCPV}"
9 9
10SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master" 10SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
@@ -28,13 +28,14 @@ inherit baremetal-image
28# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57 28# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57
29# but the examples can also be run on other architectures/machines 29# but the examples can also be run on other architectures/machines
30# such as vexpress-a15 by overriding the setting on the machine.conf 30# such as vexpress-a15 by overriding the setting on the machine.conf
31COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64" 31COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64|qemuriscv32"
32 32
33BAREMETAL_QEMUARCH ?= "" 33BAREMETAL_QEMUARCH ?= ""
34BAREMETAL_QEMUARCH:qemuarmv5 = "versatile" 34BAREMETAL_QEMUARCH:qemuarmv5 = "versatile"
35BAREMETAL_QEMUARCH:qemuarm = "arm" 35BAREMETAL_QEMUARCH:qemuarm = "arm"
36BAREMETAL_QEMUARCH:qemuarm64 = "aarch64" 36BAREMETAL_QEMUARCH:qemuarm64 = "aarch64"
37BAREMETAL_QEMUARCH:qemuriscv64 = "riscv64" 37BAREMETAL_QEMUARCH:qemuriscv64 = "riscv64"
38BAREMETAL_QEMUARCH:qemuriscv32 = "riscv32"
38 39
39EXTRA_OEMAKE:append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1" 40EXTRA_OEMAKE:append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
40 41