summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb3
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb3
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb11
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb3
4 files changed, 12 insertions, 8 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index a2fb212a68..79f2e8a092 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -10,7 +10,8 @@ SRC_URI = "file://Makefile \
10 file://COPYING \ 10 file://COPYING \
11 " 11 "
12 12
13S = "${WORKDIR}" 13S = "${WORKDIR}/sources"
14UNPACKDIR = "${S}"
14 15
15# The inherit of module.bbclass will automatically name module packages with 16# The inherit of module.bbclass will automatically name module packages with
16# "kernel-module-" prefix as required by the oe-core build environment. 17# "kernel-module-" prefix as required by the oe-core build environment.
diff --git a/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
index 90d3aefd86..8be7980919 100644
--- a/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
+++ b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
5 5
6SRC_URI = "file://helloworld.c" 6SRC_URI = "file://helloworld.c"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10do_compile() { 11do_compile() {
11 ${CC} ${LDFLAGS} helloworld.c -o helloworld 12 ${CC} ${LDFLAGS} helloworld.c -o helloworld
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index 912f6b0f61..54b834d45f 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -2,22 +2,23 @@ SUMMARY = "The canonical example of init scripts"
2SECTION = "base" 2SECTION = "base"
3DESCRIPTION = "This recipe is a canonical example of init scripts" 3DESCRIPTION = "This recipe is a canonical example of init scripts"
4LICENSE = "GPL-2.0-only" 4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4" 5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
6 6
7SRC_URI = "file://skeleton \ 7SRC_URI = "file://skeleton \
8 file://skeleton_test.c \ 8 file://skeleton_test.c \
9 file://COPYRIGHT \ 9 file://COPYRIGHT \
10 " 10 "
11 11
12S = "${WORKDIR}" 12S = "${WORKDIR}/sources"
13UNPACKDIR = "${S}"
13 14
14do_compile () { 15do_compile () {
15 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test 16 ${CC} ${CFLAGS} ${LDFLAGS} ${S}/skeleton_test.c -o ${B}/skeleton-test
16} 17}
17 18
18do_install () { 19do_install () {
19 install -d ${D}${sysconfdir}/init.d 20 install -d ${D}${sysconfdir}/init.d
20 cat ${WORKDIR}/skeleton | \ 21 cat ${S}/skeleton | \
21 sed -e 's,/etc,${sysconfdir},g' \ 22 sed -e 's,/etc,${sysconfdir},g' \
22 -e 's,/usr/sbin,${sbindir},g' \ 23 -e 's,/usr/sbin,${sbindir},g' \
23 -e 's,/var,${localstatedir},g' \ 24 -e 's,/var,${localstatedir},g' \
@@ -26,7 +27,7 @@ do_install () {
26 chmod a+x ${D}${sysconfdir}/init.d/skeleton 27 chmod a+x ${D}${sysconfdir}/init.d/skeleton
27 28
28 install -d ${D}${sbindir} 29 install -d ${D}${sbindir}
29 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ 30 install -m 0755 ${S}/skeleton-test ${D}${sbindir}/
30} 31}
31 32
32RDEPENDS:${PN} = "initscripts" 33RDEPENDS:${PN} = "initscripts"
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 8437a5a774..b0d96e7f71 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -9,7 +9,8 @@ SRC_URI = "file://file1 \
9 file://file3 \ 9 file://file3 \
10 file://file4" 10 file://file4"
11 11
12S = "${WORKDIR}" 12S = "${WORKDIR}/sources"
13UNPACKDIR = "${S}"
13 14
14PACKAGES =+ "${PN}-user3" 15PACKAGES =+ "${PN}-user3"
15 16