summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-skeleton/service/service_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-skeleton/service/service_0.1.bb')
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index 912f6b0f61..54b834d45f 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -2,22 +2,23 @@ SUMMARY = "The canonical example of init scripts"
2SECTION = "base" 2SECTION = "base"
3DESCRIPTION = "This recipe is a canonical example of init scripts" 3DESCRIPTION = "This recipe is a canonical example of init scripts"
4LICENSE = "GPL-2.0-only" 4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4" 5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
6 6
7SRC_URI = "file://skeleton \ 7SRC_URI = "file://skeleton \
8 file://skeleton_test.c \ 8 file://skeleton_test.c \
9 file://COPYRIGHT \ 9 file://COPYRIGHT \
10 " 10 "
11 11
12S = "${WORKDIR}" 12S = "${WORKDIR}/sources"
13UNPACKDIR = "${S}"
13 14
14do_compile () { 15do_compile () {
15 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test 16 ${CC} ${CFLAGS} ${LDFLAGS} ${S}/skeleton_test.c -o ${B}/skeleton-test
16} 17}
17 18
18do_install () { 19do_install () {
19 install -d ${D}${sysconfdir}/init.d 20 install -d ${D}${sysconfdir}/init.d
20 cat ${WORKDIR}/skeleton | \ 21 cat ${S}/skeleton | \
21 sed -e 's,/etc,${sysconfdir},g' \ 22 sed -e 's,/etc,${sysconfdir},g' \
22 -e 's,/usr/sbin,${sbindir},g' \ 23 -e 's,/usr/sbin,${sbindir},g' \
23 -e 's,/var,${localstatedir},g' \ 24 -e 's,/var,${localstatedir},g' \
@@ -26,7 +27,7 @@ do_install () {
26 chmod a+x ${D}${sysconfdir}/init.d/skeleton 27 chmod a+x ${D}${sysconfdir}/init.d/skeleton
27 28
28 install -d ${D}${sbindir} 29 install -d ${D}${sbindir}
29 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ 30 install -m 0755 ${S}/skeleton-test ${D}${sbindir}/
30} 31}
31 32
32RDEPENDS:${PN} = "initscripts" 33RDEPENDS:${PN} = "initscripts"