summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb')
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
new file mode 100644
index 0000000000..b1a0784c1b
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -0,0 +1,74 @@
1# linux-yocto-custom.bb:
2#
3# An example kernel recipe that uses the linux-yocto and oe-core
4# kernel classes to apply a subset of yocto kernel management to git
5# managed kernel repositories.
6#
7# To use linux-yocto-custom in your layer, create a
8# linux-yocto-custom.bbappend file containing at least the following
9# lines:
10#
11# FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
12# COMPATIBLE_MACHINE_yourmachine = "yourmachine"
13#
14# You must also provide a Linux kernel configuration. The most direct
15# method is to copy your .config to files/defconfig in your layer,
16# in the same directory as the bbappend and add file://defconfig to
17# your SRC_URI.
18#
19# To use the yocto kernel tooling to generate a BSP configuration
20# using modular configuration fragments, see the yocto-bsp and
21# yocto-kernel tools documentation.
22#
23# Warning:
24#
25# Building this example without providing a defconfig or BSP
26# configuration will result in build or boot errors. This is not a
27# bug.
28#
29#
30# Notes:
31#
32# patches: patches can be merged into to the source git tree itself,
33# added via the SRC_URI, or controlled via a BSP
34# configuration.
35#
36# defconfig: When a defconfig is provided, the linux-yocto configuration
37# uses the filename as a trigger to use a 'allnoconfig' baseline
38# before merging the defconfig into the build.
39#
40# If the defconfig file was created with make_savedefconfig,
41# not all options are specified, and should be restored with their
42# defaults, not set to 'n'. To properly expand a defconfig like
43# this, specify: KCONFIG_MODE="--alldefconfig" in the kernel
44# recipe.
45#
46# example configuration addition:
47# SRC_URI += "file://smp.cfg"
48# example patch addition (for kernel v3.4 only):
49# SRC_URI += "file://0001-linux-version-tweak.patch
50# example feature addition (for kernel v3.4 only):
51# SRC_URI += "file://feature.scc"
52#
53
54inherit kernel
55require recipes-kernel/linux/linux-yocto.inc
56
57# Override SRC_URI in a bbappend file to point at a different source
58# tree if you do not want to build from Linus' tree.
59SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
60
61LINUX_VERSION ?= "3.4"
62LINUX_VERSION_EXTENSION ?= "-custom"
63
64# Override SRCREV to point to a different commit in a bbappend file to
65# build a different release of the Linux kernel.
66# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc
67SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc"
68
69PR = "r1"
70PV = "${LINUX_VERSION}+git${SRCPV}"
71
72# Override COMPATIBLE_MACHINE to include your machine in a bbappend
73# file. Leaving it empty here ensures an early explicit build failure.
74COMPATIBLE_MACHINE = "(^$)"