summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb')
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
index cce44d9995..6194d4f8da 100644
--- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -43,9 +43,9 @@
43# 43#
44# example configuration addition: 44# example configuration addition:
45# SRC_URI += "file://smp.cfg" 45# SRC_URI += "file://smp.cfg"
46# example patch addition (for kernel v3.4 only): 46# example patch addition (for kernel v4.x only):
47# SRC_URI += "file://0001-linux-version-tweak.patch 47# SRC_URI += "file://0001-linux-version-tweak.patch"
48# example feature addition (for kernel v3.4 only): 48# example feature addition (for kernel v4.x only):
49# SRC_URI += "file://feature.scc" 49# SRC_URI += "file://feature.scc"
50# 50#
51 51
@@ -56,15 +56,14 @@ require recipes-kernel/linux/linux-yocto.inc
56# tree if you do not want to build from Linus' tree. 56# tree if you do not want to build from Linus' tree.
57SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" 57SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
58 58
59LINUX_VERSION ?= "3.4" 59LINUX_VERSION ?= "4.2"
60LINUX_VERSION_EXTENSION ?= "-custom" 60LINUX_VERSION_EXTENSION_append = "-custom"
61 61
62# Modify SRCREV to a different commit hash in a copy of this recipe to 62# Modify SRCREV to a different commit hash in a copy of this recipe to
63# build a different release of the Linux kernel. 63# build a different release of the Linux kernel.
64# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc 64# tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2
65SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc" 65SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2"
66 66
67PR = "r1"
68PV = "${LINUX_VERSION}+git${SRCPV}" 67PV = "${LINUX_VERSION}+git${SRCPV}"
69 68
70# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe 69# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe